Opened 11 years ago

Closed 11 years ago

#4713 closed defect (fixed)

GUI Tools: compress_scumm_san and _bun do not work

Reported by: criezy Owned by: sev-
Priority: normal Component: Tools
Keywords: Cc:
Game:

Description

Using the GSoC 2009 GUI tool compiled on Saturday November 28 2009 Intel mac running MacOS X 10.4.

I tried using the compress_scumm_san and compress_scumm_bun using both the GUI and the CLI. I get error with both.

With the GUI, the problem seems to come from the output selection. The GUI ask for an output directory and the file chooser only allows to select directories. But then I get the following error when it tries to run the tool:

Fatal Error Occured: Could not open file /Users/criezy/ScummVM/Test Tools/FT Compressed/

The path printed being the output directory. I tried with both vorbis and mp3 and by letting the GUI auto-detect the tool or selecting it manually. I always get the same error.

The problem with the CLI seems to be different: $ ./tools_cli FT/2009_10.san

Running using compress_scumm_san Fatal Error : Read beyond the end of file (FT/2009_10.san)

This file has no aasociated .flu file, so I tried with one that has a flu file of the same name $ ./tools_cli FT/toranch.san

Running using compress_scumm_san Fatal Error : Read beyond the end of file (toto/toranch.san)

I also tried the exact command line that is in the wiki: $ cd FT ../tools_cli --tool compress_scumm_san toranch.san

Too many inputs files ( 'uncomp/' 'comp/' )

I get the same error wether comp and uncomp directories exists or not. I also tried with the san files from COMI with the same results.

The tool extract_scumm_bun has exactly the same errors as extract_scumm_san.

Ticket imported from: #2905479. Ticket imported from: bugs/4713.

Change History (4)

comment:1 by fingolfin, 11 years ago

Tonight I applied tons of fixes to compress_scumm_san. First off, it now won't *erase* your input file accidentally anymore (this "feature" kind of... annoyed me... ;-). Next, the -o option (for specifying an output dir) should work again. By default, it'll create a file with the *same* name as the input file in the output directory. Hence, if you want to run this tool on a file in the current dir, you *must* specify -o; if you run it on a file in an external dir, you can leave -o out and it'll generate the new file(s) in the current dir.

I think more work is necessary, but this version is already a lot better, I hope.

comment:2 by fingolfin, 11 years ago

Owner: set to fingolfin

comment:3 by sev-, 11 years ago

Owner: changed from fingolfin to sev-
Resolution: fixed
Status: newclosed

comment:4 by sev-, 11 years ago

Fixed.

However there are algorithmic problems (coming from original tools) in 2 COMI files: LAVARIDE.SAN and MORESLAW.SAN. The tool asserts() in these near the end due to wrong number of frames in the header.

Note: See TracTickets for help on using tickets.