Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4701 closed defect (worksforme)

BASS crashes with BadValue exception

Reported by: SF/dotnetcarpenter Owned by:
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

Symptoms: When in full screen BASS goes to windowed screen and the F5 key (get BASS menu) is unresponsive. After a while BASS either goes to full screen again or alt+enter works again.

BASS crashes with the following: X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 130 (XFree86-VidModeExtension) Minor opcode of failed request: 10 (XF86VidModeSwitchToMode) Value in failed request: 0x4000003 Serial number of failed request: 439 Current serial number in output stream: 441

Start up info: $ sky User picked target 'sky' (gameid 'sky')... Looking for a plugin supporting this gameid... Beneath a Steel Sky Starting 'Beneath a Steel Sky' Found BASS version v0.0372 (5097 dnr entries)

Version info: Beneath a Steel Sky v0.0372 Copyright (C) Revolution Software Ltd. ScummVM engine Copyright (C) The ScummVM Team ScummVM 1.0.0rc1 (Oct 12 2009 17:02:28) Features compiled in: Vorbis FLAC MP3 ALSA zLib FluidSynth

OS: Linux dotnet-laptop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

Please bare with me I'm a newbie to scummVM. Maybe it's related to http://sourceforge.net/tracker/index.php?func=detail&aid=1286589&group_id=37116&atid=418820

Regards

Ticket imported from: #2896578. Ticket imported from: bugs/4701.

Change History (10)

comment:1 by SF/dotnetcarpenter, 10 years ago

Just found this bug https://sourceforge.net/tracker/?func=detail&aid=2878133&group_id=37116&atid=418820 It sounds very similar...

comment:2 by SF/dotnetcarpenter, 10 years ago

There seems to be a correlation between Ubuntu Visual Effects and this bug. I've tried to switch to Visual Effects: None in the Appearance Preferences window when BASS goes to windowed mode and it immediately went back to full screen mode. The downside was that F5 and alt+enter was still unresponsive, meaning that the only way to quit was to force the computer to shut down(!).

comment:3 by SF/dotnetcarpenter, 10 years ago

it just happen again while entering full screen mode in the intro. scummvm: backends/platform/sdl/graphics.cpp:781: virtual void OSystem_SDL::copyRectToScreen(const byte*, int, int, int, int, int): Assertion `_transactionMode == kTransactionNone' failed. Aborted

comment:4 by fingolfin, 10 years ago

Status: newpending

comment:5 by fingolfin, 10 years ago

Bug #2878133 (to which you referred in your first comment) was a duplicate of bug #1690813, and was fixed years ago. Unlikely to be related to the issue at hand.

I am unclear on what your steps to reproduce this are. Please tell us whether the following correctly described what you are doing; if not, please provide us with specific instructions 1) Run BASS in full screen mode 2) Hit F5 key Result: BASS becomes unresponsive and (unexpectedly) switches to windowed mode

Finally, does the issue still happen with 1.1.1 for you?

comment:6 by SF/dotnetcarpenter, 10 years ago

This bug happen on my old laptop, a DELL Precision M4400, on Ubuntu 9.04. I now how a new laptop, a Fujitsu Lifebook S710, under which Ubuntu (default) currently doesn't install.

I do however have Win7 with ScummVM 1.1.148874. I will install BASS and see if I can reproduce the bug in this setup and get back to you.

comment:7 by SF/dotnetcarpenter, 10 years ago

Status: pendingnew

comment:8 by wjp, 9 years ago

Resolution: worksforme
Status: newpending

comment:9 by SF/sf-robot, 9 years ago

This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).

comment:10 by SF/sf-robot, 9 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.