Opened 11 years ago

Closed 11 years ago

#4690 closed defect (fixed)

SAGA engine slow loading

Reported by: bluddy Owned by: sev-
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

Sometime since 0.13.0, something was introduced in Saga that causes load times on the PSP to go from the previous ~7 seconds to about 50 seconds. Everything else in the games works fine. I believe this problem was backported to the 1.0.0 branch after release of 1.0.0rc but I'm not 100% sure. In any case, though not a critical bug, this is something that should be sorted out. I hope to figure out exactly which patch caused this, hopefully with the help of the SAGA maintainers.

Ticket imported from: #2887705. Ticket imported from: bugs/4690.

Change History (4)

comment:1 by bluegr, 11 years ago

"Sometime since 0.13.0" is quite general, I'm afraid, since many changes have been made to the engine since 0.13.0. I don't have a PSP to test the regression, so you'll have to be more specific here and tell us which revision made loading so slow...

comment:2 by bluddy, 11 years ago

OK I was hoping you may have some insight due to the fact that it involves the loading code only -- loading during the game itself is fast. Since I'm going to do a regression dig-through on Kyrandia anyways I guess I'll do it on SAGA too :)

comment:3 by sev-, 11 years ago

Component: Engine: SAGA
Game: Inherit the Earth
Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:4 by sev-, 11 years ago

Ahem, this was fixed long ago. The problem was fixed by caching resource size instead of calling File.size() several thousand times on startup

Note: See TracTickets for help on using tickets.