Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4611 closed defect (fixed)

GOB3: Major graphics glitch

Reported by: SF/kuroshiro Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

Just started testing Goblin's Quest 3 CD (v1.000/Dos/English) on v.1.0.0RC1 on Windows XP.

Whenever the portrait of Blount pops of for him to say some dialogue, a large black box is left on the screen. It's cleared if you walk through it, but is still pretty annoying (see http://img41.imageshack.us/img41/9244/gob3gfx.png).

Ticket imported from: #2860261. Ticket imported from: bugs/4611.

Change History (14)

comment:1 by SF/kuroshiro, 10 years ago

Actually, this doesn't occur in a build I made today from the trunk, so it's probably safe to disregard. It happens in the RC1 binaries though, so as long as it gets fixed there it should be fine.

comment:2 by fingolfin, 10 years ago

Try making that build with optimizations enabled, i.e. pass "--enable-release" to configure and then "make clean && make". Does it still work on trunk that way?

comment:3 by SF/kuroshiro, 10 years ago

Yes, it works fine, when built under MinGW with the latest code from the trunk and with the options you specified. Only the downloadable RC1 doesn't work.

comment:4 by jvprat, 10 years ago

Component: Engine: Gob
Game: Goblins 3
Owner: set to DrMcCoy

comment:5 by fingolfin, 10 years ago

Could you try this with the daily Windows snapshot from <http://www.scummvm.org/downloads/#SVN> ?

Or maybe Kirben could make a build of the current 1.0.0 branch, just the way he made the 1.0.0rc1 binary, send it to you, and you test that -- just to make sure the 1.0.0 build (which will be made just that way) will really work fine...

comment:6 by fingolfin, 10 years ago

Owner: changed from DrMcCoy to Kirben

comment:7 by SF/kuroshiro, 10 years ago

Works fine on the latest SVN. However, there's a couple other large (one game breaking) bugs that I will report later.

comment:8 by sev-, 10 years ago

But does this bug occur with 1.0.0pre builds?

comment:9 by SF/kuroshiro, 10 years ago

No.

comment:10 by Kirben, 10 years ago

The Windows snapshots of ScummVM are already been built off the 1.0.0pre branch.

comment:11 by Kirben, 10 years ago

Owner: Kirben removed

comment:12 by Strangerke, 10 years ago

The problem is a temp sprite problem, fixed by DrMcCoy in r43655 (22/8/09). I suggest we close this one...

comment:13 by fingolfin, 10 years ago

Status: newclosed

comment:14 by fingolfin, 10 years ago

Owner: set to DrMcCoy
Resolution: fixed
Note: See TracTickets for help on using tickets.