Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4508 closed defect (fixed)

T7G: music missing in some cutscenes

Reported by: SF/kurufinwe Owned by: scott-t
Priority: normal Component: Engine: Groovie
Keywords: Cc:
Game: 7th Guest

Description

Load the attached savegame and go to the library. The big "halfway point" cutscene happens, but the music doesn't play (it plays correctly in the rest of the game).

This bug also occurred during two other cutscenes :
* the fight after solving the puzzle in the music room;
* the second part of the ending (which tends to render the ending rather underwhelming).

(I can provide saves for those two if needed)

The music was set to General MIDI (I get the "please wait while the general MIDI drivers are loaded" screen at the beginning).

Game version: The 7th Guest, DOS, English
ScummVM version: 1.0.0pre042960, Intel Mac, Mac OS X 10.5

Ticket imported from: #2831041. Ticket imported from: bugs/4508.

Attachments (1)

t7g.004 (140 bytes ) - added by SF/kurufinwe 10 years ago.
Savegame in the foyer; go to the library to see the bug

Download all attachments as: .zip

Change History (8)

by SF/kurufinwe, 10 years ago

Attachment: t7g.004 added

Savegame in the foyer; go to the library to see the bug

comment:1 by scott-t, 10 years ago

I've had a look at this one and can confirm this behaviour is occurring (and does lead to quite an underwhelming finish), but turns out to be one of a few differences between the original game DOS and Windows interpreters. The DOS behaviour is definitely the better one to implement, however it will take time to determine the correct behaviour to avoid playing music in the background at the end of other cut-scenes where it shouldn't be.

comment:2 by scott-t, 10 years ago

Not quite as hard as I had anticipated. This is now solved from r43068 in both trunk and branch. Although nothing else should break, would you be able to re-run through the game to ensure there's no unexpected regressions with music elsewhere in the game and report back here?

comment:3 by scott-t, 10 years ago

Owner: set to scott-t

comment:4 by SF/kurufinwe, 10 years ago

I don't have a lot of free time at the moment, but I'll try to replay (at least some of) the game in a few days and report here.

comment:5 by SF/kurufinwe, 10 years ago

I've replayed most of the game, only using saves to skip the most tedious puzzles (maze, piano, knights in the bathroom...). The bug is gone, and I couldn't find any music-related regression.

comment:6 by scott-t, 10 years ago

Great - means nothing unexpected showed up :)

comment:7 by scott-t, 10 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.