Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4503 closed defect

DC: 7th Guest, The (Sound Static)

Reported by: SF/scorches-forge Owned by: zeldin
Priority: normal Component: Engine: Groovie
Keywords: Cc:
Game: 7th Guest

Description

The 7th Guest, DOS.

I encountered this bug with the ScummVM "0.13.1" Dreamcast port, and I did not have the same issue with the same Windows build. I built the disc with the plain file binaries, & Bootdreams.

I notice in the Windows build it searches for some type of MIDI drivers, but when the game first load in the DC port it starts at the main menu.

The Bug:
I selected the "start new" option, the game then starts to make a garbled static sound during the intro company logos. This continues into the intro movie, up until the scene where "Stauf" is carving the doll. The first audible sentence heard is "Stauf carved the doll", and the audio seems to be okay from there.

Ticket imported from: #2830932. Ticket imported from: bugs/4503.

Change History (12)

comment:1 by sev-, 10 years ago

Status: newpending

comment:2 by sev-, 10 years ago

0.13.1 is too old. Please, test with 1.0.0pre builds and provide the results. You may find them here:

http://buildbot.scummvm.org/snapshots/1.0.0/

comment:3 by SF/scorches-forge, 10 years ago

Status: pendingnew

comment:4 by SF/scorches-forge, 10 years ago

I downloaded & burned the latest version "1.0.0pre043157", and now the game is not recognized.

comment:5 by SF/scorches-forge, 10 years ago

Let me try the same thing I used for Nippon, and use the output capacity that NullDC has to generate a debug text. I'll post the file/result tomorrow.

comment:6 by SF/scorches-forge, 10 years ago

I guess the text wouldn't help anyways as it only shows a disc change in the emulator, and not why it didn't recognize the game. This bug might as well be deleted, and I'll submit the new one to the tracker.

comment:7 by fingolfin, 10 years ago

Assigning to Marcus, our DC porter (although I am not sure whether this is really a DC issue, nor whether he even owns that game for testing).

In any case, Scorch, can you please tell us whether this issue still is there in 1.1.1 ?

comment:8 by fingolfin, 10 years ago

Owner: set to zeldin
Status: newpending

comment:9 by jvprat, 9 years ago

I just noticed this bug. I think this issue may have to do with CD-Audio: The 7th Guest plays a CD track during the first part of the intro (from "start new" until the book view). The period of time described by scorches-forge is a bit longer than that. All of this makes me think this could be a case of bad audio decoding.

scorches-forge: what settings did you use to compress the CD tracks? (MP3/OGG/FLAC, VBR/CBR, etc...)

comment:10 by zeldin, 9 years ago

If the problem might be related to compressed audio, then please also try running from the original CD, with the CDDA tracks, instead of compressing them.

comment:11 by SF/sf-robot, 9 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:12 by SF/sf-robot, 9 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.