Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4495 closed defect (invalid)

[Sam&Max] Paint-By-Number starts out all black

Reported by: SF/bobdevis Owned by: Kirben
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

Game: Sam and Max Hit the Road (PC CD)
Tested OS: Linux (Kubuntu 9.4) 64 bit
Tested ScummVM version: Jul 28 2009 SVN (my own compile)

Bug details:
When you do the Paint-by-Number minigame all the color fields are black by default. This means you have to color everything before you can actually see what it is you are doing. Obviously all the fields should start out as white by default instead.

Bug impact:
This is a very minor flaw. You can still play Paint-By-Number and the Paint-By-Number thing is not even needed to complete the game.

How to reproduce:
- Start a new game
- Do the "use" action on the rat hole in the room. (now you have money)
- Walk out of the room.
- Walk downstairs.
- Do the "use" action on the car.
- Go the south-most hamburger.
- Enter the building.
- Do the "pickup' action on the Paint-By-Number books. (in the right-bottom part of the screen)
- Walk to the store clerk on the left.
- Talk to him, use the "?" option.
- Then talk to him about the Paint-By-Number book. (now you bought it)
- Use the Paint-By-Number book.
- You are greeted by a black screen.

Ticket imported from: #2829461. Ticket imported from: bugs/4495.

Change History (6)

comment:1 by SF/bobdevis, 10 years ago

Priority: normallow

comment:2 by Kirben, 10 years ago

Not a bug, this occurs in the original Windows version of the game too.

comment:3 by Kirben, 10 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:4 by fingolfin, 10 years ago

Wait -- is this not a bug, or is it a bug that occurs in the original, too?

comment:5 by lordhoto, 10 years ago

My German DOS CD version also has the same behavior when run under DOSBox. Of course that doesn't mean it's intended to be like this in the original, but it might be just fine.

comment:6 by fingolfin, 10 years ago

Well, the intention makes all the difference here, IMO: If this behavior is intended, fine. But if it's a mistake in the original game, then we could consider adding a workaround.
I tend to agree with the reporter that it would make a lot more sense if the book was white initially... However, looking at the scripts, it uses darkenPalette() to set the palette to black. So this is definitely no simple coding mistake. Looks more like laziness, or weird design decision... ;)
So, while it would be possible to "fix" this, it really seems the authors intended this behavior. :)

Note: See TracTickets for help on using tickets.