Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4479 closed defect (fixed)

ITE: Ingame GUI does not list slots 96-99

Reported by: lordhoto Owned by: lordhoto
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

ScummVM 1.0.0pre0 r42824
Linux on PowerPC, g++ 4.3.3
Debian/unstable
Game version: English DOS CD

The ingame GUI accessed via F5 does not display save slots 96-99. It's easy to reproduce this bug: Just create a save in slot 96 via the GMM for example and then open up the ingame GUI via F5. You will notice the save is not displayed in the list.

Ticket imported from: #2827459. Ticket imported from: bugs/4479.

Change History (5)

comment:1 by SF/h00ligan, 10 years ago

for some strange reason we have following line inside saga.h:
#define MAX_SAVES 96
i think we can safely increase this value to 100

comment:2 by lordhoto, 10 years ago

Just tried increasing that define to 100, now the in-game GUI will show no more entries at all.

comment:3 by lordhoto, 10 years ago

Owner: set to lordhoto
Resolution: fixed
Status: newclosed

comment:4 by lordhoto, 10 years ago

I fixed this now, by returning 95 (to be precise MAX_SAVES - 1) as last valid save-game slot in SagaMetaEngine::getMaximumSaveSlot.

comment:5 by lordhoto, 10 years ago

Just for the logs: the in game GUI would still not display those slots, but at least now only slots displayed via the in game GUI are now accessible via the GMM.

Note: See TracTickets for help on using tickets.