Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#4458 closed defect (invalid)

RTZ: Item disappears

Reported by: SF/ezekiel000 Owned by: johndoe123
Priority: normal Component: Engine: MADE
Keywords: original Cc:
Game: Return to Zork

Description

If you use the rag to clean the rust metal thing the rag disappears, does this happen in the original?
Because you need the rag to complete the game.

Ubuntu 9.04 amd64, ScummVM svn42646, RtZ CD/DOS/English v1.2

Ticket imported from: #2826006. Ticket imported from: bugs/4458.

Attachments (1)

rtz.001 (35.5 KB) - added by SF/ezekiel000 9 years ago.
Rag and metal thing in inventory.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 10 years ago by bluegr

I'm pretty sure that the rag is supposed to disappear at this place. I don't remember having the rag when finishing the game myself...

comment:2 Changed 10 years ago by SF/ezekiel000

I can't remember when I played with the original exe but the guide I was using seemed to think it should still be there, I guess it needs testing in dos or windows with the original exe.

comment:3 Changed 10 years ago by fingolfin

What is the status of this item?

comment:4 Changed 10 years ago by fingolfin

Owner: set to johndoe123

comment:5 Changed 10 years ago by johndoe123

It still has to be confirmed if this also happens in the original.
If this actually is a bug it's most likely in the original game scripts and not the reimplemented engine.

comment:6 Changed 9 years ago by bluegr

Just checked my old saved games, I did have the rag in my inventory. So this situation didn't happen for me. Did you try this in a different screen, just in case? This does seem to be an obscure script bug

comment:7 Changed 9 years ago by bluegr

Also, can you attach a saved game where this occurs?

Changed 9 years ago by SF/ezekiel000

Attachment: rtz.001 added

Rag and metal thing in inventory.

comment:8 Changed 9 years ago by SF/ezekiel000

I've attached my first save which has both the rag and metal thing in the inventory. It is in a different location than where I tested it before (last time I tested it where you pick up the metal thing I think) and when I tried to clean the metal thing with the rag, the rag disappeared.

comment:9 Changed 9 years ago by bluegr

My saved games are dated 8th-12th of May, 2008, i.e. revisions 31944 - 32081. So if this is a regression, it must have happened after rev 31944 - need to double check with my saved games.

comment:10 Changed 8 years ago by sev-

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:11 Changed 8 years ago by sev-

Priority: normalhigh

comment:12 Changed 8 years ago by digitall

The attached savegame can not be loaded by current Git master development, but this is likely to be due to the savegame being corrupt/older version.
The message produced is:
"WARNING: Unexpected save game size. Expected 91000, size is 90998!"

This was probably broken by 305954d34a612f14bdaad2cda9f982498f4f7066 by bluegr.
Save game headers are now verified

svn-id: r35848

comment:13 Changed 8 years ago by digitall

Though this may also be due to the slight difference in my game version:
Return to Zork - English CD version 1.0 9/15/93

comment:14 Changed 8 years ago by digitall

Just to update status and clarify: It appears that RTZ English V1.0 and V1.1+ savegames are incompatible (Though v1.1 and v1.2 seem to be similar enough to not have issues). Since I only have RTZ v1.0 currently, and the v1.2 patch doesn't seem to work to update this, I don't think I can investigate this. Sorry.

comment:15 Changed 7 years ago by sev-

Priority: highnormal

comment:16 Changed 6 years ago by bluegr

This is normal game behavior. If you try and clean the rusty metal thing, the rag disappears. You need to rub the rusty metal thing with the rug if you don't have the mirror at that point, in order to reflect Canuk's duck spell. If you have the mirror, you can happily keep both the rug and the rusty metal thing as they are, and use them in the end of the game to lower the bridge.

Thus I'm closing this as invalid / occurs in the original

comment:17 Changed 6 years ago by bluegr

Keywords: original added
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.