Opened 10 years ago

Closed 10 years ago

#4435 closed defect (invalid)

ITE: compressed sounds don't play

Reported by: SF/dhwz Owned by:
Priority: high Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

When compressing VOICES.RSC or SOUNDS.RSC of English DOS CD version of ITE with compress_saga.exe, tried it with mp3 and vorbis, ScummVM can't play it (playing noises instead of speech/sounds).
I have tried it with build (1.0.0svn42532) and 0.13.1

I've checked a tempfile.mp3 which is created with compress_saga.exe and its already broken then, only noisy sound, no voices...

Ticket imported from: #2823873. Ticket imported from: bugs/4435.

Change History (7)

comment:1 by SF/dhwz, 10 years ago

.

comment:2 by SF/dhwz, 10 years ago

Summary: ITE compressed voices don't playITE compressed sounds don't play

comment:3 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:4 by sev-, 10 years ago

Priority: normalhigh
Summary: ITE compressed sounds don't playITE: compressed sounds don't play

comment:5 by SF/dhwz, 10 years ago

tempfile.mp3 was just a coincidence

Problem is solved when I replaced both sounds.rsc and voices.rsc with the sounds.cmp and voices.cmp. I first tried to replace only the voices.rsc that caused the noise. If I only replace sounds.rsc I get the noise too. I think there is some problem with the saga engine?

comment:6 by SF/dhwz, 10 years ago

Resolution: worksforme

comment:7 by sev-, 10 years ago

Resolution: worksformeinvalid
Status: newclosed
Note: See TracTickets for help on using tickets.