Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4323 closed defect (fixed)

PS2: COMI: game freezes

Reported by: SF/risedchristof Owned by: sunmax
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Config: ScummVM 0.13.1 PS2; Game in English

On PS2 during gameplay, each time the game is saved the game freezes.
It's necessary to reset the console, but when I go to the memory card, no data was saved.

Same thing happens playing the game via DVD, or via USB drive.

Ticket imported from: #2785537. Ticket imported from: bugs/4323.

Change History (9)

comment:1 Changed 10 years ago by SF/risedchristof

Summary: PS2 Monkey Island freezePS2 Monkey Island 3 freeze

comment:2 Changed 10 years ago by jvprat

Owner: set to sunmax

comment:3 Changed 10 years ago by sunmax

Dear Christof,

we are aware of the bug - if you check the README that comes with the release,
it's actually number #1 on our bugs list. It all boils down to a stack corruption
when starting COMI (aka Monkey Island 3) and maybe RTZ. We are investigating
the cause, but due to limited debugging tools on the PS2 this kind of issue can
take a while. It's interesting that you can make it to save the game: is that the
game save manu or the GMM? Cause for me and few other users it just locks
when popping GMM.

Regards,
-max

comment:4 Changed 10 years ago by SF/risedchristof

At beginning it started to block at GMM, but later on I deleted all data from the memory card regarding the SCUMMVM and started again. That way I was able to start the game, but noticed that the game freezed after 5 minutes. Later on I deleted again everything from the memory card, and started again the game but without the autosave mode. That way I was able to play the game as long as I wanted, but as I pressed start to save game it blocked again.

Best regards

comment:5 Changed 10 years ago by sev-

Summary: PS2 Monkey Island 3 freezePS2: COMI: game freezes

comment:6 Changed 10 years ago by sev-

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:7 Changed 10 years ago by sev-

Priority: normalhigh

comment:8 Changed 10 years ago by sunmax

As of 2009-07-12 fixed in branch-0-13-0 and trunk.

Closed.

comment:9 Changed 10 years ago by sunmax

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.