Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#4233 closed defect (worksforme)

FT: Overlapping voice/music in cutscenes

Reported by: SF/meddlingmonk Owned by: sev-
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Starting with version 13 and continuing through 14svn, FT has had a problem with overlapping sounds (music and voice) in cutscenes. I'm pretty sure that it didn't exist in version 12 but I haven't kept a copy of that. Uploaded save file is at beginning of the cutscene starting with Ben chasing Mo and ending back at the mink farm with Ripburger's two henchmen. When you listen to Ben, the Cavefish leader, and Nestor speaking, you can hear the lines coming too quick--the following portion starting even before the previous has stopped. Same for music. Different cues overlap. The problem is especially pronounced toward the end, after the bridge is blown up. This isn't a problem with all cutscenes (the opening seems normal).

Ticket imported from: #2688144. Ticket imported from: bugs/4233.

Attachments (2)

ft.s05 (16.5 KB ) - added by SF/meddlingmonk 11 years ago.
Cutscene of Ben chasing Moe/Trucker geting wasted
ft.s32 (16.8 KB ) - added by eriktorbjorn 11 years ago.
New savegame, shortly before the cutscene

Download all attachments as: .zip

Change History (12)

by SF/meddlingmonk, 11 years ago

Attachment: ft.s05 added

Cutscene of Ben chasing Moe/Trucker geting wasted

by eriktorbjorn, 11 years ago

Attachment: ft.s32 added

New savegame, shortly before the cutscene

comment:1 by eriktorbjorn, 11 years ago

I can reproduce the problem with ft.s05, but not when playing the game from the beginning up to that part. I've attached my savegame, in case someone wants to investigate what's different between them. (I don't have the time right now, and quite possibly not the know-how.)
File Added: ft.s32

comment:2 by SF/meddlingmonk, 11 years ago

Did you ever pause the game or leave it long enough for the inbuilt screensaver to activate? If not, maybe that's it. I dismissed it as paranoia at the time but I seemed to start encountering the problem after a pause. I actually paused more than once while playing and at least once during a cutscene. Maybe that's the trigger.

comment:3 by eriktorbjorn, 11 years ago

No, I didn't. I played through the game (up to that point) as quickly as I could, before I had to leave for work.

comment:4 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:5 by sev-, 10 years ago

Priority: normalhigh

comment:6 by SF/meddlingmonk, 10 years ago

I haven't been able to reproduce this. I had thought it might have been triggered by either pausing the game or by letting its screensaver activate, but after several attempts there seems to be nothing I can do to deliberately cause overlapping audio.

comment:7 by fingolfin, 10 years ago

Very wild guess, but maybe this is related to the subtitle speed/delay setting?

comment:8 by SF/meddlingmonk, 10 years ago

Would it matter if this is a setting I've never, ever touched?

comment:9 by sev-, 9 years ago

I cannot reproduce it either.

comment:10 by sev-, 9 years ago

Owner: set to sev-
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.