Opened 12 years ago

Closed 12 years ago

Last modified 2 years ago

#4216 closed defect (fixed)

SCI: password for LSL5

Reported by: SF/bellut Owned by: bluegr
Priority: low Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 5

Description

LSL5 features the option of protecting the installed game with a password you need to enter if you want to start the game (after the intro). Password information is stored in the file MEMORY.DRV; when using the original interpreter deleting this file removes the set password and the game allow the player to set a new one or go ahead without a password at all.

lsl5-MEMORY.DRV is created on the first start of LSL5 within ScummVM but the game asks for a password which is unknown and most likely consists of random garbage. Deleting the file has no effect other that it beeing re-created on the next start of the game.

This behaviour is present in both the standalone PC version and the version from Greatest Hits and Misses.

Ticket imported from: #2672575. Ticket imported from: bugs/4216.

Attachments (3)

log.txt (21.0 KB ) - added by SF/bellut 12 years ago.
debug log
log2.txt (20.4 KB ) - added by SF/bellut 12 years ago.
debug log without lsl5-MEMORY.DRV
lsl5-MEMORY.DRV (96 bytes ) - added by SF/bellut 12 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 by fingolfin, 12 years ago

In general, it is far too early to submit bug reports on the SCI engine, as we haven't even finished integrating it.

But since this concerns an area of the code for which I needed examples of how SCI games actually use it... :).

So, please tell us * what OS are you on? * what ScummVM version do you use? * please run ScummVm with "-d3" as command line argument and attach the output to this tracker (as a file, please, not as a super long comment ;).

Thanks!

comment:2 by fingolfin, 12 years ago

Owner: set to fingolfin
Priority: normallow

by SF/bellut, 12 years ago

Attachment: log.txt added

debug log

comment:3 by SF/bellut, 12 years ago

File Added: log.txt

comment:4 by SF/bellut, 12 years ago

OS: Linux nermal.bellut.net 2.4.19-32mdkcustom #1 Thu Jun 12 04:25:21 CEST 2003 i686 unknown unknown GNU/Linux

scummvm: 39261

log is attached

comment:5 by fingolfin, 12 years ago

Thanks!

Just to confirm: If you delete lsl5-MEMORY.DRV and then start again, it does create it again, empty?

comment:6 by fingolfin, 12 years ago

In particular: Can you please delete lsl5-MEMORY.DRV, and then make another run and attach the debug log of that?

by SF/bellut, 12 years ago

Attachment: log2.txt added

debug log without lsl5-MEMORY.DRV

comment:7 by SF/bellut, 12 years ago

File Added: log2.txt

by SF/bellut, 12 years ago

Attachment: lsl5-MEMORY.DRV added

comment:8 by SF/bellut, 12 years ago

File Added: lsl5-MEMORY.DRV

comment:9 by SF/bellut, 12 years ago

It creates a new lsl5-MEMORY.DRV, yes, but it's not empty. I've attached the created file, which BTW was identical to the previous generated file, for your reference.

comment:10 by wjp, 12 years ago

According to lskovlund this is caused by a known string handling problem.

comment:11 by bluegr, 12 years ago

This has been fixed now, with commit #39876, which was caused by the incorrect handling of the XOR encrypted password string in kStrAt(). Thanks to lskovlund's comments and help on this issue, it has been resolved.

Please note that for some reason (which seems to be unrelated to this), it's NOT currently possible not to set a password (you'll get the password screen anyway the next time, and it won't work). Just create a password, and accept the default value of "NONE" (which is the empty password).

Closing.

comment:12 by bluegr, 12 years ago

Owner: changed from fingolfin to bluegr
Resolution: fixed
Status: newclosed

comment:13 by digitall, 2 years ago

Component: Engine: SCI
Game: Leisure Suit Larry 5
Note: See TracTickets for help on using tickets.