Opened 11 years ago

Closed 9 years ago

#4192 closed defect (fixed)

TUCKER: Slow Walking

Reported by: SF/prefix331 Owned by: cyxx
Priority: normal Component: Engine: Tucker
Keywords: Cc:
Game: Bud Tucker

Description

ScummVM 0.13.0pre win32 English Version Talkie

It does seem to me like Bud sometimes walk very VERY slow, i've attached a savegame of this so you can check if this is the case with your versions as well.

Altso some sprites seems to be missing i am getting these errors in scummvm.exe

WARNING: Unable to open 'charsize.dta'! WARNING: Unable to open 'sprites/a26_03.spr'! WARNING: Unable to open 'sprites/a16_04.spr'! WARNING: Unable to open 'sprites/c11_08.spr'! WARNING: Unable to open 'sprites/c19_10.spr'! WARNING: Unable to open 'sprites/a27_07.spr'!

a26_03 was repeated three times during my short 20min play.

Ticket imported from: #2627967. Ticket imported from: bugs/4192.

Attachments (2)

tucker.5 (357 bytes ) - added by SF/prefix331 11 years ago.
slow walking bud save
tucker.2 (319 bytes ) - added by SF/prefix331 11 years ago.
2nd issue with the slow walking bug

Download all attachments as: .zip

Change History (18)

by SF/prefix331, 11 years ago

Attachment: tucker.5 added

slow walking bud save

comment:1 by SF/prefix331, 11 years ago

Owner: set to cyxx

comment:2 by fingolfin, 11 years ago

Summary: Slow WalkingTUCKER: Slow Walking

comment:3 by fingolfin, 11 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by SF/prefix331, 11 years ago

I've run into this bug again now, it seems to happen alot after loading multiple times. added another savegame with the bug.

by SF/prefix331, 11 years ago

Attachment: tucker.2 added

2nd issue with the slow walking bug

comment:5 by SF/prefix331, 11 years ago

Update: Tested this with the newest daily snapshot, still the same thing.

comment:6 by cyxx, 11 years ago

Unless you experience graphics glitches, it's safe to ignore these warnings about sprites and charset.

comment:7 by SF/prefix331, 11 years ago

Okay, anyway this still happens to me sometimes, after repeatedly loading my game or alt tabbing, or alt+enter to fullscreen/window mode, Bud will walk at half his speed and will continue to do so until you restart the game. Random occurance i think.

comment:8 by sev-, 11 years ago

May it happen that Tucker engine has full screen updates, which slows down the system?

comment:9 by cyxx, 11 years ago

full screen updates should only occur on room scrolling/new room background etc. I can't reproduce the "very slow" issue with any of 2 savegames neither by loading repeatedly.

prefix331, when the problem occurs, do the background animations also slow down? or only Bud walking is affected ?

comment:10 by cyxx, 11 years ago

Status: newpending

comment:11 by SF/prefix331, 11 years ago

Status: pendingnew

comment:12 by SF/prefix331, 11 years ago

Only bud was affected. I recently reformatted and i haven't reinstalled Double Trouble yet, i'll get on it though :)

comment:13 by raziel-, 10 years ago

I thought to open a new item but as this is still valid and open i'll add it here

It's ego walking speed only, it's the overall speed that is too slow (even on a machine where every other demanding game runs perfectly fine)

Ego *is* slowing down on entering a new room and fadeing into the scene is performed

Main problem and as such that would also solve the "slow walking" issue is the overall speed of the whole game. One feels as if playing in slowmotion

Just for comparison i played shortly in DosBox and watched some YouTube videos, the speed in both is realtime, unfortunately not so in ScummVM

comment:14 by cyxx, 9 years ago

Resolution: fixed

comment:15 by cyxx, 9 years ago

There was another delay introduced by the fadePalette calls. It should fixed with commit da77a057d17c3985632e704b5cff88ef6729beed

comment:16 by cyxx, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.