Opened 12 years ago

Closed 12 years ago

Last modified 2 years ago

#4175 closed defect (fixed)

SCUMM: Saving/loading disabled from GMM

Reported by: SF/henjovr Owned by: SF/tanoku
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

Since the recent GMM hotkey change to CTRL-F5 the saving/loading in the GMM seems to be disabled.

engines/scumm/input.cpp:465 :

if (mainmenuKeyEnabled && (lastKeyHit.keycode == Common::KEYCODE_F5 && lastKeyHit.flags == 0)) {

Should be:

if (mainmenuKeyEnabled && (lastKeyHit.keycode == Common::KEYCODE_F5 && lastKeyHit.flags == Common::KBD_CTRL)) {

More engines may also be affected.

Ticket imported from: #2612313. Ticket imported from: bugs/4175.

Change History (4)

comment:1 by SF/henjovr, 12 years ago

Sorry, my proposed fix was too hasty and nonsense. But still, saving/loading in GMM is disabled.

comment:2 by lordhoto, 12 years ago

I can not reproduce that over here neither with trunk nor branch-0-13-0. It seems to be the case that the save/load functionality is disabled when the F5 menu is also disabled. At least for me it is only disabled in GMM when I can not open the F5 menu. I guess that's normal though.

comment:3 by Kirben, 12 years ago

Component: --Unset--
Owner: set to SF/tanoku
Resolution: fixed
Status: newclosed

comment:4 by digitall, 2 years ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.