Opened 11 years ago

Closed 10 years ago

#4156 closed defect (fixed)

TUCKER: Sprite error

Reported by: SF/prefix331 Owned by: cyxx
Priority: high Component: Engine: Tucker
Keywords: Cc:
Game: Bud Tucker

Description

When entering the old man's box in the park after giving him a hamburger, Bud's sprite can be seen standing in the left corner of the room.

ScummVM 0.13.0pre
win32

Ticket imported from: #2597763. Ticket imported from: bugs/4156.

Attachments (3)

budbug2.JPG (42.3 KB ) - added by SF/prefix331 11 years ago.
Picture of the error
tucker.2 (318 bytes ) - added by SF/prefix331 11 years ago.
Savegame inside the old man's box. Bud's sprite is in the left corner
tucker.3 (316 bytes ) - added by SF/prefix331 11 years ago.
2nd savegame outside box

Download all attachments as: .zip

Change History (21)

by SF/prefix331, 11 years ago

Attachment: budbug2.JPG added

Picture of the error

comment:1 by Kirben, 11 years ago

Owner: set to cyxx
Summary: Sprite errorTUCKER: Sprite error

comment:2 by SF/prefix331, 11 years ago

Forgot to mention i'm running the English version

comment:3 by SF/prefix331, 11 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by SF/prefix331, 11 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:5 by SF/prefix331, 11 years ago

This is the talkie, i copied all the required files to my harddrive.
Sorry for not posting everything at once, i couldn't find a way to edit the Summary.

comment:6 by SF/prefix331, 11 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:7 by SF/prefix331, 11 years ago

When entering the old man's box in the park after giving him a hamburger,
Bud's sprite can be seen standing in the left corner of the room.

In order to replicate this bug just play up to where you get inside the man's box, it'll be there.

ScummVM 0.13.0pre
English
talkie
win32

No older versions support this game.

(Updated summary)

comment:8 by cyxx, 11 years ago

can you attach a savegame ? thanks

comment:9 by fingolfin, 11 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:10 by fingolfin, 11 years ago

Status: newpending

comment:11 by SF/prefix331, 11 years ago

Adding the savegame you wanted.

comment:12 by SF/prefix331, 11 years ago

Status: pendingnew

by SF/prefix331, 11 years ago

Attachment: tucker.2 added

Savegame inside the old man's box. Bud's sprite is in the left corner

comment:13 by SF/prefix331, 11 years ago

Update: Upon retesting this bug does not appear in the savegame i have added, this is because you have to actually walk through the door to have the glitch appear, i've added a second savegame where you just have to talk to Royston and watch the dialogue, once you've entered the box you will see the glitch.

by SF/prefix331, 11 years ago

Attachment: tucker.3 added

2nd savegame outside box

comment:14 by SF/prefix331, 11 years ago

Tested in ScummVM 0.14.0svn.
Still not working.

comment:15 by sev-, 10 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:16 by sev-, 10 years ago

Priority: normalhigh

comment:17 by cyxx, 10 years ago

Resolution: fixed
Status: newclosed

comment:18 by cyxx, 10 years ago

should be fixed with svn revision 42458

Note: See TracTickets for help on using tickets.