Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4056 closed defect (fixed)

Wii: T7G Crash

Reported by: SF/philski Owned by: dhewg
Priority: normal Component: Engine: Groovie
Keywords: Cc:
Game: 7th Guest

Description

Version: ScummVM 0.13.0svn (scummvm-wii-svn_r35520_20081224)
Platform: Wii
(English language/original European release)

When trying to run the game it freezes during the opening titles.

After pressing start the intro plays up to the Trilobyte logo and the audio track will continue to play to the end after this a hard reset of the system is required.

Ticket imported from: #2472070. Ticket imported from: bugs/4056.

Change History (19)

comment:1 by jvprat, 11 years ago

Thanks for reporting this. I was able to reproduce it. dhewg suggested it may be an issue with libfat when doing lots of small reads, which would be fixed when the readahead cache is reimplemented on the Wii port. Anyway I'll try to have a look at it by my side, but it's hard to debug without the proper tools.

comment:2 by jvprat, 11 years ago

Owner: set to jvprat

comment:3 by dhewg, 11 years ago

It was not related to libfat. The problem was udelay() in libogc, a fix just got commited to svn, and i merged it into git:
http://git.hackmii.com/git.php?p=libogc.git&a=commitdiff&h=3f0ba9c5284ae50d2f79adda1483ca2290ad92cf&hb=62dbf6710349e71d83096dad3cc65cf418b99cd8&tm=1367790

This fixes all calls to delayMillis() with msecs ~ > 2000. The drascula intro now plays fine, too ;)

I'll post a build on the forums soon, please confirm the fix.

comment:4 by SF/philski, 11 years ago

As of the latest build (scummvm-wii-svn_r35736_20090105) the issue persists.

comment:5 by dhewg, 11 years ago

Works for me, a bugfix for this went into libogc, not the ScummVM SVN.
I linked to the diff on my last comment. The build on the forums i posted (rev35709) includes this. By the revision you mentioned i assume you built your own binary, are you sure the fix is included?

comment:6 by sev-, 11 years ago

Status: newpending

comment:7 by sev-, 11 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:8 by SF/philski, 11 years ago

I've tried running with 35709 however it seems to be even more unstable. The animation usually freezes during the Virgin logo and the audio garbles. The furthest I have managed to get is halfway through the opening credits.

comment:9 by SF/philski, 11 years ago

Status: pendingnew

comment:10 by SF/philski, 11 years ago

Okay, could part of the problem be that I had the game in a subdirectory inside the ScummVM folder? I moved it into a different directory

The intro has now played all the way through, but with stuttering audio. Also in between each page in the introduction a different piece of music attempts to play.

Other more minor glitches include:

In game there is no lipsync with the actors and their speech.

Animation throughout is a little choppy.

Many thanks for all the support!

comment:11 by SF/philski, 11 years ago

UPDATE: It now appears that the game is unstable. This morning a loaded it up again and it ran fine, however I've just attempted to run it again (exactly the same configuration) and it is freezing at the Virgin/Trilobyte logos once more.

Sorry for these multiple updates.

comment:12 by SF/robintheilade, 11 years ago

With the version scummvm-wii-svn_r35795_20090109.rar by Bossk found in the forum I got a little longer than to the Virgin logo and passed the trilobyte logo but then it stalled at the 7th guest logo and the music froze.

comment:13 by jvprat, 11 years ago

I'm assigning it to dhewg since it's definitely an issue with the Wii port. The original deterministic bug was fixed (it hanged with big sleeps), but the user experience hasn't changed: now it's crashing in random places but I can't even reach the 7th guest logo.

comment:14 by jvprat, 11 years ago

Owner: changed from jvprat to dhewg

comment:15 by dhewg, 11 years ago

This problem only occurs when the CD audio tracks are available as audio files. With these, as it turns out, results in the same deadlock Hkz and me noticed experiences on FT and COMI.
The bug is in newlib itself, and the changes have not yet been committed (you have to rebuild your libc).
I just posted a build (rev 35811) on the forums, please test this.

The lockup shouldn't happen anymore.

comment:16 by SF/philski, 11 years ago

As of rev 35811 the issue appears to be solved!!!

Many thanks to all those that worked to fix it :)

The game still runs slowly in many parts and speech is usually out of sync with the characters. I don't know if this can be optimised. But these are far less serious problems and unrelated to the original submission. Should these be set up as a separate report?

Thanks again!

comment:17 by jvprat, 11 years ago

I'm closing it since dhewg finally managed to fix it. It seems the problem was in newlib's thread scheduler, so a new release of the toolchain is required to build.

philski: Yes, open a new report about that, thanks.

comment:18 by jvprat, 11 years ago

Resolution: fixed
Status: newclosed

comment:19 by dhewg, 11 years ago

awwwww, i wanted to close this one :P

but seriously: i'm really glad this issue has been resolved, it got frustrating at times.

I posted my fix on the newlib mailinglist, if it gets accepted (or another way to resolve this issue is found), i'll update the build instructions on the wiki.

Thanks alot for the testing!

Note: See TracTickets for help on using tickets.