Opened 12 years ago

Closed 12 years ago

#4012 closed defect (fixed)

FT: Crash in the intro (regression in r34516)

Reported by: jvprat Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

At the beginning of the introduction, before Mr. Corley ends his first line seen from the inside of the car, ScummVM gives this error: (1:60:0x86): SMRK has an invalid size : 120!

I've tracked it down to r34516. With r34515 it's working fine again.

I'm using the Spanish version of Full Throttle (I don't know whether this also happens with other versions), in uncompressed form.

Ticket imported from: #2299682. Ticket imported from: bugs/4012.

Change History (7)

comment:1 by fingolfin, 12 years ago

Guess this is my fault, then. I'll look into it when / once I have time. But if somebody beats it to me, that is fine by me, too ;(,

comment:2 by eriktorbjorn, 12 years ago

I tried, but I don't understand your change. ;-)

The test for subSize != 0 for appears to have been added in r34516. Before that, any value was ok as far as I can see. I don't know if the test was added deliberately or by accident.

comment:3 by fingolfin, 12 years ago

Torbjörn, great, go ahead and fix it. I am busy at a conference and with my thesis and don't plan to make any commits for the next couple weeks anyway, nor do i remember what that change was about -- all I saw was that I made that commit :).

comment:4 by fingolfin, 12 years ago

Owner: set to eriktorbjorn

comment:5 by eriktorbjorn, 12 years ago

Ok, I've removed that check. But I'm too tired to try it with uncompressed movie files and the English version tonight. Jordi, could you check if the problem is gone (and that it hasn't caused any further regressions), please?

comment:6 by jvprat, 12 years ago

I've tried now playing until meeting Maureen and it didn't crash anymore. Thanks!

comment:7 by eriktorbjorn, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.