Opened 12 years ago

Closed 11 years ago

#4005 closed defect (fixed)

FF: Crackling Audio (Mac version) on Wii and OSX

Reported by: SF/philski Owned by: dhewg
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

The crackling sound found in the Mac version of Feeble Files is audible in the Wii release of ScummVM 0.12.0

Ticket imported from: #2211901. Ticket imported from: bugs/4005.

Attachments (1)

Feeble Files Intro.mp3 (213.0 KB ) - added by SF/philski 11 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 by fingolfin, 12 years ago

I am confused -- it sounds as if you were saying that the audio data of the mac version of Feeble Files is distorted, and that the Wii version faithfully reproduces the resulting crackling. If so, then this would not be a bug report, as we would be doing everything correct -- bad audio is bad audio, and we couldn't do anything about it.

But I probably just mistunderstood you. Could you please clarify?

comment:2 by SF/philski, 12 years ago

Hi there,

Sorry for the confusion. Back when Feeble Files was added to ScummVM the Mac version (at least in OS X) had crackling sound wjen playing the game. As of version 0.9.1 this issue has been resolved (the notes for this version state: "Fixed crackling sound in Mac version of Feeble Files"), However in the current Wii release of ScummVM the crackling is once again an issue.

Hope that has made more sense.

comment:3 by bluegr, 12 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by SF/philski, 12 years ago

* ScummVM version: 0.12.0 * Bug details: Upon starting the game the audio crackles loudly. This is audible through both cutscenes and gameplay, but not the game menu * Language of game: English * Version of game: Mac 3CD European release * Platform and Compiler: Wii * Attach a save game: No save game required to reproduce bug

Many thanks!

comment:5 by fingolfin, 12 years ago

Owner: set to dhewg

comment:6 by dhewg, 12 years ago

I cannot test this game at the moment, but could you please verify if this still occurs on the Wii build i just posted on the Wii subforums?

comment:7 by SF/philski, 12 years ago

I've just tested using scummvm-wii-svn_r35736_20090105

Sadly, the bug remains.

comment:8 by SF/philski, 12 years ago

As of rev 35811 this is still an issue

comment:9 by sev-, 11 years ago

What is the status of this item?

comment:10 by SF/philski, 11 years ago

It still seems to be an issue and as of (at least) version 0.13.1 has become an issue again in the OS X build

comment:11 by dhewg, 11 years ago

"in the OS X build" Do you still mean the OSX version of Feeble Files or do you mean this issue happens with ScummVM _for_ OSX too?

comment:12 by dhewg, 11 years ago

Hm, thinking about this item again: It may not be specific to the Mac version at all. Maybe data off SD couldn't be read fast enough, and that results in the crackling.

Can you test a recent snapshot? A few cache changes have been commited to the base libraries since your last report, the I/O throughput has been increased significantly.

What kind/brand of SD card are you using? Do you have another one you can try?

comment:13 by SF/philski, 11 years ago

Sorry for not replying sooner. I meant this issue also happens with ScummVM _for_ OSX too (at least on the Power PC build).

I'm unable to test a recent Wii build just now, however the audio glitch is identical to the one made when playing the game on OS X. Although read speed may be an issue as well, it isn't the same sort of audio stuttering that happens in other games (such as Broken Sword).

I have attached an audio clip of an example of what can be heard launching Feeble Files from both the Wii and OS X. This was recorded when launching the game in the 0.13.1 Power PC build for OS X.

The only time this sound is not heard is when there is no audio playing (i.e. on the game menu screen).

by SF/philski, 11 years ago

Attachment: Feeble Files Intro.mp3 added

comment:14 by dhewg, 11 years ago

Summary: Wii Audio: Feeble FilesFF: Crackling Audio (Mac version) on Wii and OSX

comment:15 by dhewg, 11 years ago

Thanks for the clip!

For OSX, the SDL backend uses double buffering, just like the Wii port.

The Windows version of FF seems fine, just as the Mac version when using the Windows port (verified by Kirben). It's possible that a buffer couldn't be filled fast enough.

comment:16 by SF/philski, 11 years ago

No problem! I've just downloaded the 1.0.0pre043157 OS X PPC build and I'm afraid the issue is still there. I hope to be able to try out the Wii build later this evening.

comment:17 by dhewg, 11 years ago

We found the problem, its an endian issue with ADPCM streams. I have a working fix here, but clone is going to clean up the endian mess in that decoder.

comment:18 by SF/philski, 11 years ago

Congrats! Thanks so much for all the effort!

comment:19 by fingolfin, 11 years ago

Resolution: fixed
Status: newclosed

comment:20 by fingolfin, 11 years ago

Sorry for closing this, I was (incorrectly) under the impression that it had been fixed, based on the comments here. Reopening. Seems dhewg has a patch for this issue as tracker item #2834677.

comment:21 by fingolfin, 11 years ago

Resolution: fixed
Status: closednew

comment:22 by dhewg, 11 years ago

Resolution: fixed
Status: newclosed

comment:23 by dhewg, 11 years ago

Fixed in r43287 and r43288, please test the next nightly build

Note: See TracTickets for help on using tickets.