Opened 13 years ago

Closed 13 years ago

#4002 closed defect (fixed)

BS1 Demo: Crash due to missing speech segment

Reported by: SF/simsaw Owned by: eriktorbjorn
Priority: normal Component: Engine: Sword1
Version: Keywords:
Cc: Game: Broken Sword 1

Description

When you look at the working man, the game crashs. I found out that this is due to missing speech segment. When removing the speech file speech/cows.mad, the game instead displays the subtitle. So in the fix that should be made the subtitles should be displayed even in speech only mode if the speech segment can't be found in the speech file.

I've tested the Broken Sword 1 Demo with the official current daily snapshot for Windows (Oct 20).

Ticket imported from: #2182450. Ticket imported from: bugs/4002.

Change History (3)

comment:1 by eriktorbjorn, 13 years ago

The speech is there, but apparently the decoded length of it isn't stored at the beginning, like it is in the other demo sounds. I don't know if it's the best way to do it, but I've added a workaround where if the length doesn't appear to be there, it figures out the length by going through the motions of decoding the sound, without actually writing to any output buffer.

It seems to be working for me, but could you please test it too?

comment:2 by eriktorbjorn, 13 years ago

I've played through the demo. I didn't trigger all lines of speech, of course, but I didn't notice any regressions. I also didn't notice any other speech that needed this special treatment. I guess the fix is good enough, at least for now.

comment:3 by eriktorbjorn, 13 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.