Opened 12 years ago

Closed 12 years ago

Last modified 2 years ago

#3976 closed defect (fixed)

ALL: Starting the launcher with -f triggers assertion

Reported by: DrMcCoy Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

In the current SVN version (r34610), starting ScummVM with -F (and fullscreen=true in ~/.scummvmrc) triggers

scummvm: backends/platform/sdl/graphics.cpp:696: void OSystem_SDL::setFullscreenMode(bool): Assertion `_hwscreen != 0' failed.

Starting games directly from the commandline with -F works correctly.

Backtrace: #3 0x00000000004077e4 in OSystem_SDL::setFullscreenMode (this=0x15be640, enable=true) at backends/platform/sdl/graphics.cpp:696 #4 0x000000000040c27d in OSystem_SDL::setFeatureState (this=0x15be640, f=OSystem::kFeatureFullscreenMode, enable=true) at backends/platform/sdl/sdl.cpp:401 #5 0x000000000040e274 in launcherDialog (system=@0x15be640) at base/main.cpp:68 #6 0x000000000040e758 in scummvm_main (argc=2, argv=0x7fff954846d8) at base/main.cpp:285 #7 0x000000000040b387 in main (argc=2, argv=0x7fff954846d8) at backends/platform/sdl/main.cpp:108

Ticket imported from: #2120602. Ticket imported from: bugs/3976.

Change History (5)

comment:1 by lordhoto, 12 years ago

It's caused by lines 67+68 in base/main.cpp. Commenting out gives wrong behavior when returning from game to launcher, if the game has no full screen option set while the launcher has: It would end up in the launcher without full screen. I guess that might be preferable over a broken full screen startup though. :-)

comment:2 by lordhoto, 12 years ago

Summary: ALL: Starting the launcher with -F triggers assertionALL: Starting the launcher with -f triggers assertion

comment:3 by fingolfin, 12 years ago

Status: newclosed

comment:4 by fingolfin, 12 years ago

Owner: set to fingolfin
Resolution: fixed

comment:5 by digitall, 2 years ago

Component: GUI
Note: See TracTickets for help on using tickets.