Opened 11 years ago

Closed 11 years ago

#3879 closed defect (duplicate)

IHNM: Crash when trying to speak with the 2 entity

Reported by: SF/iraito Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: I Have No Mouth

Description

i have installed the italian traduction for IHNM, the game is ever gone good, but when i arrived in front the russian and chinese entity and try to speak with their the game goes in crash:

two immages:

http://img523.imageshack.us/img523/6841/problemwa0.jpg

http://img145.imageshack.us/img145/2763/beforeofthecrashsf9.jpg

ScummVM 0.11.1

Ticket imported from: #2057901. Ticket imported from: bugs/3879.

Attachments (1)

patchIHNMAIMS_v2.0.zip (202.8 KB ) - added by SF/iraito 11 years ago.
The italian traduction(if it serve)

Download all attachments as: .zip

Change History (11)

by SF/iraito, 11 years ago

Attachment: patchIHNMAIMS_v2.0.zip added

The italian traduction(if it serve)

comment:1 by SF/iraito, 11 years ago

Summary: Crash when i try to speeck with russian & chinese entityIHNM Crash when i try to speeck with the 2 entity

comment:2 by bluegr, 11 years ago

Can you please attach a savegame?

comment:3 by fingolfin, 11 years ago

The error message sounds as if this is a bug in the italian translation you are using. Can you tell us where this version you are using is coming from? Is it a patch to be applied to the english version, or what?

comment:4 by fingolfin, 11 years ago

Summary: IHNM Crash when i try to speeck with the 2 entityIHNM: Crash when trying to speak with the 2 entity

comment:5 by SF/glorifindel, 11 years ago

I've mailed this bug to thebluegr some time ago, revision 30988 http://scummvm.svn.sourceforge.net/viewvc/scummvm?view=rev&revision=30988 should had fixed it, can you try with latest SVN build?

comment:6 by SF/glorifindel, 11 years ago

Tried the latest SVN, the bug is fixed

comment:7 by fingolfin, 11 years ago

Owner: set to bluegr

comment:8 by fingolfin, 11 years ago

Great! So, thebluegr, could you please (a) augment the source code comment added in 30988 to refer to this bug report (so that when we later may have to revise that code, it's clear why that workaround is in there), and (b) afterwards close this report? Thanks :)

comment:9 by bluegr, 11 years ago

Resolution: duplicate
Status: newclosed

comment:10 by bluegr, 11 years ago

Hm, after reviewing this bug, it's actually a duplicate of another bug, which has been fixed in the 0.12.0 branch and the trunk. Refer to bug #1895205 - "IHNM: end game text/caption error": http://sourceforge.net/tracker/index.php?func=detail&aid=1895205&group_id=37116&atid=418820

The relevant commit that fixed it is #30985: http://scummvm.svn.sourceforge.net/viewvc/scummvm?view=rev&revision=30985

Closing as duplicate

Note: See TracTickets for help on using tickets.