Opened 12 years ago

Closed 12 years ago

#3743 closed defect (fixed)

WOODRUFF:Transportozon crash

Reported by: SF/kuroshiro Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Woodruff

Description

**Scummvm version: 0.12.0 svn **Language: English **Platform: Win32

Simply, if you try to use the transportozon under certain conditions at the end of the game to transport to "At the Bigwig's", the game will crash. The procedure to create the crash is:

Hypnotize the bigwig Use the vibelfrotzer (sp?) on the Bigwig Do not skip the cutscene (not sure if this effects anything) Leave via the window. Teleport to the cui-cui store. Get the chewing gum, and step back. Teleport back to the Bigwig's. The game will then crash. It will NOT crash if you teleport from other locations, and you can still walk in.

I included a saved game from which you can test the above procedure.

Ticket imported from: #1972462. Ticket imported from: bugs/3743.

Attachments (1)

woodruff-gb.s06 (21.4 KB ) - added by SF/kuroshiro 12 years ago.
Saved game at the Bigwig's

Download all attachments as: .zip

Change History (15)

by SF/kuroshiro, 12 years ago

Attachment: woodruff-gb.s06 added

Saved game at the Bigwig's

comment:1 by SF/kuroshiro, 12 years ago

Summary: Transportozon crashWOODRUFF:Transportozon crash

comment:2 by DrMcCoy, 12 years ago

Owner: set to DrMcCoy

comment:3 by DrMcCoy, 12 years ago

Could you please try with a current repository checkout / next daily build? If the cause is what I think it is, it should be fixed now.

comment:4 by SF/kuroshiro, 12 years ago

Just tested the same procedure outlined above in version: ScummVM 0.12.0svn (May 26 2008 21:53:11) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The first time I did the same procedure, the game crashed. The second time I tested (with debug output on, running from the console with "-d1 --debugflags=DrawOpcodes,FuncOpcodes") the game did not crash. From then on every time I tested it, it was fine, no matter how I started it.

comment:5 by DrMcCoy, 12 years ago

Hmm, are you sure that's already a new daily build since I commited that fix? (Yes, I always get confused by the dating of the daily build, since the time on the homepage differs from the time the GUI shows differs from my local time)

comment:6 by SF/kuroshiro, 12 years ago

Tested it again for a 4th time for good measure, and the crash occured again, albeit the screen actually loaded this time before the crash occured. Same version ScummVM 0.12.0svn (May 26 2008 21:53:11) The crash seems to not occur when scummvm is started from the command line, but to occur occasionally when it is started from a desktop shortcut. Not sure if it's actually related to that (or how it even would be).

comment:7 by SF/kuroshiro, 12 years ago

Just tested it again for good measure, and this time the game crashed again, albeit after loading the screen, unlike before where it would crash before even loading. This was the same version as before (ScummVM 0.12.0svn (May 26 2008 21:53:11)

It never seems to happen when scummvm is run from the command line, only when run from a desktop shortcut, though I have no idea how this would effect it. I tried it again with the debug output on and again it didn't crash. Strange.

comment:8 by DrMcCoy, 12 years ago

Well, I'd still say (and hope ;)) it's not yet been a new daily build. The bug I fixed are invalid reads in Scenery::renderStatic(), Scenery::updateStatic() and Scenery::updateAnim(), and these often crash in a random, unreliable manner. So, just to be sure, please wait for the next daily build.

comment:9 by SF/kuroshiro, 12 years ago

I tested it using an SVN version that I downloaded about 15 minutes ago, so unless it's been updated again since then, it is the most recent version.

comment:10 by DrMcCoy, 12 years ago

Yes, but what I meant is that the it's a _daily_ build, i.e. it's updated once a day. The one you've downloaded could still be the old one, without my fix.

Anyway, there are apparently more invalid reads I didn't notice earlier, this time in Video::retrace(), so there's also still something wrong with my split screen handling (for the non-scrolling screen part with the hotspot texts). :/

comment:11 by SF/kuroshiro, 12 years ago

Yeah, I got it. I'm pretty sure you're right and that it hasn't updated with your fix yet, looking at the times on the build and in the svn repository (Fix is about 5 hours ago while the build is more like 10). So I'll test it again when the new build comes out.

And yeah, there's always more bugs to fix :( but you're doing a fantastic job on the engine, and squashing those bugs; keep it up.

comment:12 by DrMcCoy, 12 years ago

Just fixed the (hopefully last) split screen problem. The next daily build really shouldn't crash anymore.

comment:13 by SF/kuroshiro, 12 years ago

Tested it a few more times on the newest daily build (ScummVM 0.12.0svn (May 27 2008 09:33:19)) and it did not crash. Seems to be fixed :)

comment:14 by DrMcCoy, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.