Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3730 closed defect (invalid)

FOA: IQ points not awarded when launching torpedo

Reported by: SF/denizoezmen Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: original Cc:
Game: Indiana Jones 4

Description

During the wits path in FOA, firing Indy through the torpedo tube out of the submarine should earn the player 9 IQ points. This does not seem to work, however.

To reproduce, use the attached save game and pull the clothesline in the inventory. The current IQ points should increase from 238 to 247, the total should increase from 968 to 977. Neither of these happens.

- Tested with ScummVM versions:
- 0.9.1 (Oct 24 2006 11:00:13)
- 0.10.0svn (May 8 2007 09:31:31)
- 0.11.1 (Feb 24 2008 12:46:21)
- 0.12.0svn (May 22 2008 15:09:29)
- Game: FOA English PC CD Talkie
- Platform: Win32, pre-compiled binaries

Please note: The attached save game is based on one created while playing the game with the 0.9.1 release. Is it thus possible that this behaviour does not indicate a "current" bug, but an old one instead, which has affected the save game?

In other words, can someone confirm whether or not the IQ points are awarded correctly?

Thanks!

Ticket imported from: #1969846. Ticket imported from: bugs/3730.

Attachments (1)

atlantis.s01 (24.1 KB ) - added by SF/denizoezmen 11 years ago.
FOA wits path, Indy in torped tube

Download all attachments as: .zip

Change History (7)

by SF/denizoezmen, 11 years ago

Attachment: atlantis.s01 added

FOA wits path, Indy in torped tube

comment:1 by SF/denizoezmen, 11 years ago

Summary: IQ points not awarded when launching torpedoFOA: IQ points not awarded when launching torpedo

comment:2 by eriktorbjorn, 11 years ago

I get points for escaping the submarine, both using this savegame (though it behaved a bit strangely for me), and using one of my own. Before I pulled the clothesline, I had 238 current points. Afterwards, I had 247. (The total score didn't change, probably because I had already done this part before.)

comment:3 by SF/denizoezmen, 11 years ago

That is odd. I just double-checked (using a freshly installed virtual machine) that the current points are not updated in my case.

In which way did the save game act strangely?

Digging through the resources and following the debug output, it seems that there are two objects called "clothesline". Both of them contain the "firing" code and the change to room 33 in response to the pull event, but only one of them calls "startScript(144,[106,9])", which I assume is setting the IQ points.

Obviously, the second object code should be used, but for some reason the first one (which looks a bit like pre-release code to me, but I might be mistaken) gets called on my system (it's also stored in the save game).

Needless to say, I'm a bit confused ...

comment:4 by eriktorbjorn, 11 years ago

> In which way did the save game act strangely?

There was a clothesline in my inventory (which I didn't notice until a few minutes ago), and I had to climb out of and re-enter the torpedo tube before I could pull the clothesline in the scene. (The clothesline in my inventory vanished in the process.) I've never seen that happen before.

I also noticed now that with the savegame, it's possible to pull the clothesline in my inventory, and that doesn't seem to award any points.

comment:5 by SF/denizoezmen, 11 years ago

Ahh, that was a valuable observation!

I've dug out my old save games from playing FOA with the original interpreter. (The copy in question is the German PC floppy version, but that shouldn't matter for demonstration purposes.)

I verified that there are two ways to fire Indy out of the torpedo tube after tieing the clothesline to the lever:

First method:
- Walk into the torpedo tube.
- Close the tube door.
- Pull the clothesline seen on the main screen. Indy will automatically open the door, pick up the clothesline and close the door again.

Second method:
- Walk into the torpedo tube.
- Pick up the clothesline seen on the screen.
- Close the tube door.
- Pull the clothesline seen in the inventory.

The first method will correctly increase the IQ points, while the second will fail to do so.

In summary, this behaviour is present in the original interpreter as well, so it's not a ScummVM bug. Thus, I'm marking this thread closed/invalid.

Sorry for wasting your time and thanks for the help!

Best wishes,

Deniz Oezmen

comment:6 by SF/denizoezmen, 11 years ago

Keywords: original added; script removed
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.