Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3702 closed defect

LURE: actionCTR exceeded

Reported by: SF/mystic3 Owned by: dreammaster
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

Game: Lure of the Temptress
ScummVM o.ii.i Win 32.exe for Windows XP
Game runs fine with sound. I'm 3/4 thru the game but when I'm in the apothercary shop and want to talk to Goewin or give her the cowbane, in the Dos window I get the message: Warning! actionCtr exceeded. And she just gets a question mark over her head. Can't get any farther in the game.
Engish version of game
Win 32 for wndows XP
Attached is saved game where bug occurs

Ticket imported from: #1944644. Ticket imported from: bugs/3702.

Attachments (1)

lure.005 (21.1 KB ) - added by SF/mystic3 12 years ago.
saved game where bug occurs

Download all attachments as: .zip

Change History (17)

by SF/mystic3, 12 years ago

Attachment: lure.005 added

saved game where bug occurs

comment:1 by Kirben, 12 years ago

Component: Engine: SCUMM

comment:2 by Kirben, 12 years ago

Component: Engine: Lure
Game: Lure of the Temptress
Owner: set to dreammaster

comment:3 by dreammaster, 12 years ago

Did you by any chance start playing the game with an earlier version of ScummVM? There's a known problem if you transfer a savegame saved at a certain point to the newer versions of the game engine, this can happen - due to differences in the way Goewin is handled, the game thinks she's walking around, so tries to move you right up to her when you talk to her, rather than walking to the front of the counter. That's why you get the warning.

To help resolve this issue, I've committed an extension to the debugger. If you compile the source, or wait until the next daily SVN is available, you can go into the debugger using 'Ctrl-D', and enter the command: script 52

This will execute the script associated with making Goewin work in the apothecary, and will properly reset her details so you can interact with her.

comment:4 by SF/mystic3, 12 years ago

Hello: Thank you for the help. I didn't start playing with an earlier version of ScummVM. I also tried to move closer to Goewin on the side as well as other places, but whne I try to talk to her, I get moved back to the front of the counter and still get the warning of actionCTR exceeded. So I guess I need to use the extension that you created, except I have no idea how to use it. How do I complie the source?? Or how do I go into the debugger so that I can use the ctrl-D command? Sorry, but this is all new to me:-)..Can you walk me thru what i need to do?...Thanks..Gary

comment:5 by dreammaster, 12 years ago

Certainly. First of all, if you're not experienced with compiling the source code, it'll be easier for you to wait for the next daily SVN build (Apr 19) to become available in the ScummVM Downloads section.

Load up your savegame, and press Ctrl-D.. this is the hotkey for starting the debugger, so if you press it, you should see thedebugger window open. From there, you type: 'script 52' (without the quotes) and press Enter. Then press Escape to exit the debugger. You should be able to talk to her then.

It's somewhat concerning if this problem can happen with a fresh game started on 0.11.1 - I'm going to leave this bug open for now; I'll need to run some experiments and see if I can figure out why this problem could still be occuring, and under what circumstances.

comment:6 by fingolfin, 12 years ago

Summary: Lure: actionCTR exceededLURE: actionCTR exceeded

comment:7 by SF/mystic3, 12 years ago

Hello: Sorry to be so challenged..But here's where I'm at. I went to the download section at ScummVN. Found the SVN section, found the daily download at the snapshot page, downloaded the file for 4/19 into the game directory. Opened the saved game, did the Ctrl-D. The debugger window opened, typed in script 52 with no quotation marks, and got the message 'unknown command'. I obviously did somethng wrong...can you help me out?...Thanks again...Gary

comment:8 by dreammaster, 12 years ago

You seem to be doing everything correctly.. the only thing I can suggest is to make sure that ScummVM says '0.12.0svn (Apr 19 2008) or later when you start it up, just to make sure you aren't accidentally still running an older ScummVM version. If the command script 52
still doesn't work, I just downloaded the Apr 20 SVN version and confirmed the code is active, so you might want to re-download the daily SVN again and try it with that.

comment:9 by SF/mystic3, 12 years ago

Hello: When I hit Ctrl-D to open the command window in the saved game, its says ScummVN 011.1 not 0.12svn, so somehow the other version hasn't loaded which is what the problem seems to be. Is that version automaticaaly included in the download that I did or do I need to find that else where? If it is included, I don't know what to do to get it to run in place of the O.11.1 version. What I downloaded was the file on the snapshot page that has the date 200080419 listed and is called scummvm.exe 20080419_unstripped.bz2. Is that the correct file? If not I'm not sure where to find the on that says 0.12snv...again sorry for the lack of technology savvy...I'm usually pretty good at this stuff..Gary

comment:10 by dreammaster, 12 years ago

Since you said in your original bug report that you're running Windows XP, you need to download the scummvmwin32.exe file with the link "Win32 Daily Snapshot" in the downloads section of the ScummVM website. This file contains an installer which installs a ScummVM group under Program Files you can use to launch the newest version.

comment:11 by SF/mystic3, 12 years ago

Hello: Success! That fixed the problem...however, now the colors in the game are all very different. It's hard to differentitate between things...everything is very yellow/orange and all the people in the game are black, no color at all. That happened with the new ScummNV version, not after I initiated the script 52 command. Can you fix the colors so that they're back to normal? Thanks...Gary

comment:12 by dreammaster, 12 years ago

Sounds like with the newer version you're starting in EGA mode - the game was originally designed to run on both EGA as well as VGA monitors. What you'll likely need to do is remove the game entry from the ScummVM menu and then re-add it, explicitly selecting that you want the VGA version. Don't worry, this won't erase your savegames.

comment:13 by SF/mystic3, 12 years ago

Hello: I just wanted to thank you for all of the help. The game is back to normal and running fine. I look forward to finishing it. Thanks again..Gary

comment:14 by bluegr, 12 years ago

So it's a bug fixed in the latest SVN version

Should this be closed Paul?

comment:15 by dreammaster, 12 years ago

I think I will close it. I tried playing the game from the start up to that point and didn't have any trouble talking to Goewin. Given that mystic3 was somewhat inexperienced with knowing what version of ScummVM was being run, I'm going to chalk it up to that he had actually started the game with an earlier version, since I know that the problem can occur in that circumstance. If anyone ever gets the problem again I can look into it further then.

comment:16 by dreammaster, 12 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.