Opened 12 years ago

Closed 11 years ago

#3666 closed defect (fixed)

MONKEY: cannot restart during the intro

Reported by: SF/breach Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 1

Description

ScummVM version: 0.11.1 win32-release Secret of Monkey Island CD/VGA, 2.3b, English, PC, win32(Vista x64)

Steps to reproduce:

1. Start Secret of Monkey Island under ScummVM 2. During the intro sequence (as soon as the LucasFilm logo appears) press F8 3. Confirm you want to restart the game

Result: ERROR: (10:176:0xAB): Script 176 ending with active cutscene/override (1)

Guess restart tries to terminate the script, but a script is not allowed to end with a running cutscene?

Ticket imported from: #1923193. Ticket imported from: bugs/3666.

Change History (4)

comment:1 by fingolfin, 12 years ago

Summary: Secret of Monkey island: cannot restart during the introMONKEY: cannot restart during the intro

comment:2 by Kirben, 12 years ago

Well that error is valid, judging by disassembly for this game.

So the error must be due to difference in how we currently handle restarting the game.

comment:3 by Kirben, 11 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:4 by Kirben, 11 years ago

Fixed in ScummVM SVN, use the next daily snapshot of ScummVM SVN.

The cutsceneOverride field wasn't been cleared by killAllScriptsExceptCurrent(), for all games (only SCUMM version 6). Which meant a cutsceneOverride value could already exist, when a script slot was later re-used.

Note: See TracTickets for help on using tickets.