Opened 12 years ago

Closed 12 years ago

#3627 closed defect (fixed)

PUTTZOO: Music in water scenes messed up

Reported by: raziel- Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Putt-Putt Saves the Zoo

Description

ScummVM 0.12.0svn (Feb 16 2008 12:17:05) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The music in the water scenes (waterfall, jungle stream, Kenya scene etc.) is messed up. There is (instead of the water noise) some "thump, thump" played during the whole scene.

It is also present in 0.11

ScummEngine_v72he readMAXS: MAXS has blocksize 40

Putt-Putt Saves the Zoo (Windows)

AmigaOS4 gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1894968. Ticket imported from: bugs/3627.

Change History (7)

comment:1 by sev-, 12 years ago

Better to test it with zoodemo from humongous FTP (f3d55aea441e260e9e9c7d2a187097e0 zoodemo.he0). Right on the first screen after demo.

Though they apparently fixed it in zoodemo which comes with Farm CD (de4efb910210736813c9a1185384bace zoodemo.he0).

This is not a regression, introduced in 0.8.1. 0.8.0 plays it OK.

comment:2 by sev-, 12 years ago

It was introduced in commit 20054 (backport to branch-0-8-0). Haven't narrowed it down in trunk/

comment:3 by sev-, 12 years ago

Commit 20040 to trunk

comment:4 by eriktorbjorn, 12 years ago

If it's the same as in the demo, the sound of running water is started very frequently (a poor man's looping, perhaps?). If the sound had still been playing, the ScummVM mixer would have ignored the duplicate sound, but the sound is stopped first. In current SVN, it's the stopHandle() on line 646 of sound_he.cpp.

comment:5 by Kirben, 12 years ago

Is this actually a ScummVM specific issue though? as I hear the same waterfall sound effects, in the original version of the game.

I think this was a bug in the HE72 version, considering this issue doesn't effect the later 98.5 version of Putt-Putt Saves the Zoo.

comment:6 by Kirben, 12 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:7 by Kirben, 12 years ago

The problem was due to a code difference in o72_getResourceSize() opcode, between HE72 and HE73 versions.

The default HE version of puttzoo was previously marked as HE72, when it should have been HE73.

Note: See TracTickets for help on using tickets.