Opened 17 years ago

Closed 17 years ago

#360 closed defect (fixed)

MI1VGA: more graphical glitches

Reported by: SF/inguin Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

OK, here's the list for the rest of the game. Again: I only
noticed graphical glitches and walking box bugs, there
was not a single gameplay problem. And of course I'm
again offering any screenshots or savegames you might
need.

Sea Monkey:
1. Guybrush gets covered by parts of his desk and his
bed in his room.
2. On top of the ship's mast, you can walk around freely.
3. Guybrush shines through boxes and barrels at the
store room, even if he stands behind them.
4. In the crew bed room, Guybrush can walk through the
bed in the middle of the room.
5. After opening his locker and placing the chest at the
floor, Guybrush gets covered by that chest.
6. Guybrush gets covered by the cannon.

Monkey Island:
7. Guybrush gets covered by several palm trees at the
beaches
8. Guybrush can walk through a rock at the dam.
9. If you fell from the cliff and see that "Sierra Death
Message", the vultures are drawn above the window.
10. At the top view of the island, the beaches are often
lined in a wrong colour (depending on which room you
were in before).
11. The three-headed monkey at the cannibal village
misses part of one head.
12. If you found your way to LeChuck's ghost ship and
walk down to it, Guybrush is visable all the way though he
walks down behind a rock.
13. At the ghost ship, Guybrush is visible through several
pillars and a bed (hard to notice, because you only see
his outline).
14. After opening the trap door in the room with the
chickens, Guybrush can still walk across it.

Hope it helps.

Ticket imported from: #583053. Ticket imported from: bugs/360.

Attachments (3)

monkeyvga.s10 (35.5 KB ) - added by SF/inguin 17 years ago.
Aboard the Sea Monkey
monkeyvga.s11 (37.0 KB ) - added by SF/inguin 17 years ago.
LeChuck's ghost ship
monkeyvga.s01 (35.3 KB ) - added by SF/inguin 17 years ago.
Fresh savegame for part 2

Download all attachments as: .zip

Change History (16)

comment:1 by SF/inguin, 17 years ago

Priority: normallow

comment:2 by fingolfin, 17 years ago

A save game on the ship would be helpful (I currently have
no save games there).

Also one for issue 14 (could be a walkbox bug).

by SF/inguin, 17 years ago

Attachment: monkeyvga.s10 added

Aboard the Sea Monkey

comment:3 by SF/inguin, 17 years ago

No problemo! I hope our copies of MI are compatible.

by SF/inguin, 17 years ago

Attachment: monkeyvga.s11 added

LeChuck's ghost ship

comment:4 by fingolfin, 17 years ago

Hey, 2 is really cool :-) Maybe we should leave that in on
purpose? <g> Anyway, i think it it caused by some of my
recent box changes. There is only one walk box there: [140 x
98] [140 x 98] [140 x 98] [140 x 98]. This is not handled
correctly. I will look into it.

comment:5 by fingolfin, 17 years ago

2 is fixed in CVS now (turned out it wasn't my fault after
all :-)

Bug 4 seems like another box bug, will look at it now. Bugs
1, 3, 4, 5 seem like masking bugs.

comment:6 by fingolfin, 17 years ago

4 is *not* a walkbox bug, it falls into the same category
(masking bug) as 1, 3, 5, 6, 7, 12, 13. So if somebody fixes
the masking stuff, a big bunch of problems should be solved
at once.

8 - I don't see any problems at the damnn. Which rock do you
mean exactly?

9 - can't reproduce

10 - possibly related to o5_lights?

14 doesn't seem to be a bug, it is the same in the "normal"
Monkey Island. There are no boxes being locked, etc. I can't
confirm it right now, but IIRC the original behaved the same.

comment:7 by SF/inguin, 17 years ago

Update:
2, 4, 6, 7, 8, 9, 11: fixed
1: mostly gone

comment:8 by fingolfin, 17 years ago

1 is mostly gone?!? hu?

For me, 4 is still there (he's not walking thru the bad,
just drawn incorrectly), and so is 6. Didn't check the others.

by SF/inguin, 17 years ago

Attachment: monkeyvga.s01 added

Fresh savegame for part 2

comment:9 by SF/inguin, 17 years ago

These bugs occur only if I load my old savegame. I'm uploading a
"fresh" one, which I created today.

comment:10 by SF/ender, 17 years ago

Can you rewrite the two buglists with whats broken CURRENTLY as a new
bug? I want to close these two, they are getting hard to follow :)

comment:11 by SF/inguin, 17 years ago

Sorry, I'm leaving for a one week-trip to Norway tomorrorw.
Unless anybody else feels obliged to verify my buglists, you'll
have to wait a few days.

comment:12 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:13 by fingolfin, 17 years ago

can't reproduce any of these (well 14 seems to be
normal as stated before). Feel free to open a new bug if
you still find other issues (or if you can reproduce any of
these).
Endy, when we make the next release we gotta tell
people that save games may be broken. The
MonkeyVGA graphics and Zak256 walkboxes are just
two things that can be screwed up in old save games

Note: See TracTickets for help on using tickets.