Opened 13 years ago

Closed 5 years ago

#3591 closed defect (fixed)

COMI: Glitch when turning pages in recipe book

Reported by: eriktorbjorn Owned by:
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Latest SVN snapshot English version of the game

When turning pages in the recipe book (found on Blood Island), there is a brief moment where it displays text from two different pages at the same time.

Since blast texts are cleared as soon as they're drawn, I guess we don't draw them often enough.

Ticket imported from: #1878514. Ticket imported from: bugs/3591.

Attachments (2)

book.jpg (52.9 KB ) - added by eriktorbjorn 13 years ago.
Screenshot of glitch
comi.s21 (93.6 KB ) - added by eriktorbjorn 13 years ago.
Savegame with the recipe book

Download all attachments as: .zip

Change History (15)

by eriktorbjorn, 13 years ago

Attachment: book.jpg added

Screenshot of glitch

by eriktorbjorn, 13 years ago

Attachment: comi.s21 added

Savegame with the recipe book

comment:1 by eriktorbjorn, 13 years ago

File Added: comi.s21

comment:2 by eriktorbjorn, 13 years ago

Or maybe we update the screen too often.

comment:3 by sev-, 11 years ago

Priority: normalhigh

comment:4 by sev-, 11 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:5 by fingolfin, 10 years ago

Owner: set to fingolfin

comment:6 by fingolfin, 10 years ago

Can somebody confirm whether this happened in the original game?

The cause is clear, and I'll shortly commit a workaround: Local script 2007 draws the recipe text; when changing pages, this script is stopped by script 2006, then respawned; but the blast text is not cleared in between, hence for one game tick, both old and new text are drawn simultaneously.

This looks to me like a script bug, a missing call to clearTextQueue(). But *maybe* it hints at a bug in our rendering / script pipeline. E.g. maybe we shouldn't draw that new text yet? Seems pretty unlikely to me, though, as we'd likely be seeing far more errors.

Hence I am very much interested in hearing how the original engine performs in this scene!

comment:7 by fingolfin, 10 years ago

Resolution: fixed

comment:8 by fingolfin, 10 years ago

See r48207.

comment:9 by fingolfin, 10 years ago

Priority: highnormal

comment:10 by fingolfin, 10 years ago

Lowering priority, as the actual issue has been fixed, for now at least.

comment:11 by fingolfin, 10 years ago

Priority: normallow

comment:12 by fingolfin, 9 years ago

Owner: fingolfin removed

comment:13 by sev-, 5 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.