Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#3586 closed defect (fixed)

AGI: Character loses final walking position

Reported by: raziel- Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Goldrush

Description

ScummVM 0.12.0svn (Jan 20 2008 08:26:47)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Click somewhere with the mouse to send the charcter.
Then type something while the character walks and
press enter, then discard the popped up window with
enter and see what happens ...
the character doesn't stop at the intende position
rather he continues in the same direction until some
obstacle stops him

Walk code with final destination seems to be
interrupted and changed/killed/erased

Gold Rush! (1.01 1989-01-13 aka 2.05 1989-03-09/Amiga/English)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1875842. Ticket imported from: bugs/3586.

Change History (12)

comment:1 Changed 11 years ago by wjp

You don't actually need to press enter. Pressing any key should do the trick. It should be reproducable in any AGI game.

This happens because any key press resets the ADJ_EGO_XY flag in keyboard.cpp, handleController() without clearing direction if that was set by the ADJ_EGO_XY feature.

It might not be safe to reset direction when clearing ADJ_EGO_XY since ADJ_EGO_XY is also used by cmd(adj_ego_move_to_x_y).

comment:2 Changed 11 years ago by wjp

Summary: AGI GR: Character looses final walking positionAGI: Character loses final walking position

comment:3 Changed 10 years ago by sev-

Owner: set to sev-
Resolution: wontfix
Status: newclosed

comment:4 Changed 10 years ago by sev-

No, this is how AGI is supposed to work and is intended behavior. The main reason is that AGI initially had only directions, and the actor _has_ to follow the choosen direction after the user inut.

I checked with original, as well as with other implementations. Rejecting.

comment:5 Changed 10 years ago by wjp

I thought the mouse-targetted walking was an enhancement over the original AGI engine, but maybe I'm wrong.

Are there original AGI games with mouse support? The ones I tried all only had keyboard support.

comment:6 Changed 10 years ago by sev-

Amiga versions used mouse.

comment:7 Changed 10 years ago by sev-

Resolution: wontfix
Status: closednew

comment:8 Changed 10 years ago by sev-

Reopening this:

raziel> I wrote thsi because on Amiga it DOES NOT loose the final destination on pressing
raziel> RETURN or clicking away a text window.
raziel>
raziel> The whole item was meant for the mouse support in Amiga versions.

Well, only if you would stressed that at the beginning :)

I will try to look into that.

comment:9 Changed 10 years ago by sev-

okay, what does happen if you provide some legit command like 'look'? Does the actor continues going to the destination?

comment:10 Changed 10 years ago by raziel-

Yes.

On pressing RETURN ego just walks along tofinal destinantion and stops

On typing e.g. "look" and clicking away the pop-up window, does make ego walk to the final destinantion and stop aswell

comment:11 Changed 9 years ago by sev-

Fixed in svn.

comment:12 Changed 9 years ago by sev-

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.