Opened 11 years ago

Closed 11 years ago

#3490 closed defect (fixed)

LURE: Assertion with Ratpouch(?)

Reported by: raziel- Owned by: dreammaster
Priority: blocker Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

ScummVM 0.11.0svn (Dec 8 2007 11:45:13)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

In front of the Apothecary with Gwyn
assertion "destCharacter" failed: file "engines/lure/hotspots.cpp", line 1669
on talking about how to reach the dragon.

Lure of the Temptress (English/DOS)

Amiga OS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1847210. Ticket imported from: bugs/3490.

Attachments (2)

lure.010 (21.0 KB) - added by raziel- 11 years ago.
Send away ratty and talk to Gwyn
debuglog_lure.zip (72.4 KB) - added by raziel- 11 years ago.
Debuglog as wished

Download all attachments as: .zip

Change History (15)

comment:1 Changed 11 years ago by dreammaster

Could you please attach a savegame from just prior to the talk to make it easier to test?

comment:2 Changed 11 years ago by dreammaster

Owner: set to dreammaster
Status: newpending

Changed 11 years ago by raziel-

Attachment: lure.010 added

Send away ratty and talk to Gwyn

comment:3 Changed 11 years ago by raziel-

Status: pendingnew

comment:4 Changed 11 years ago by raziel-

I was just about to do so :-)
As it crashed i had to reboot, sorry

It's a little tricky to reproduce
You first have to send away Ratpouch to somewhere else
then talk to Gwyn (btw, yes, she is stuck, dunno why, she
doesn't move a muscle) about Dragons, when finished,
immediately click on the sign above the apothecary.
Gwyn will say "Hello, my dear" and the game will stuck

btw: Not the right for this, i know, but do you need me to
file single bugreports on every "pathfinding" bugs i found
so far or could i merge them into one?
found so far
File Added: lure.010

comment:5 Changed 11 years ago by dreammaster

It's probably best to post a single combined bug report for any pathfinding problems - chances are any anomolies are closely related in any case.

comment:6 Changed 11 years ago by sev-

Raising priority. This is a release-critical bug.

comment:7 Changed 11 years ago by sev-

Priority: normalblocker

comment:8 Changed 11 years ago by dreammaster

Could I get you to test the latest build for the save problem? The current code has only one point in hotspots.cpp that does an assert(destCharacter), and that's in the doAsk routine (which handles Ask actions).. but from your bug report the bug was triggered by doing a 'talk to' Gwyn and then looking at the sign. I can't remember anywhere else in the code that did that, but it's possible one of my recent code fixes has removed one.

If you can get the error on the newest build, could you tell me if the error is the same, and what the module/line number is. It would also be useful if you could run the game in debug mode with the flags:
--debuglevel=3 --debugflags=animations,scripts,hotspots,strings

and upload it here? Thanks.

comment:9 Changed 11 years ago by raziel-

With pleasure

ScummVM 0.11.0svn (Dec 15 2007 18:23:10)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

assertion "destCharacter" failed: file "engines/lure/hotspots.cpp", line 1691

debuglog attached

Note:
It may not be a problem with Gwyn afterall, as i tested it
WITHOUT sedning Ratty away, it seemed that if he stays in
the same screen with Diermont everything is ok.

Problem is as soon as i send him away (steps follow)

Tell Ratpouch to
Go to
The Forge
and then
Ask
Catriona
Cowbane
and then
Go to
Smithy Street
and then
Get
Cowbane
and then
Go to Apothecary Street
and then
finish

the assertion appears, although NOT immediately after i
talked to Catriona and clicked on the sign, a few seconds
pass and then it appears

It may be because Ratpouch gets stuck on his way to the Forge?

Changed 11 years ago by raziel-

Attachment: debuglog_lure.zip added

Debuglog as wished

comment:10 Changed 11 years ago by raziel-

Summary: LURE: Assertion on GwynLURE: Assertion with Ratpouch(?)

comment:11 Changed 11 years ago by raziel-

Uploaded debuglog for real now

...and it doesn't matter if you talk to Gwyn. The error is
not affected by her et al, it only happens when you perform
the steps on sending Ratty.
Seems he DOES get stuck on his way to The Forge summoning
the assertion (shame on me for blaming old ladys) :-(
File Added: debuglog_lure.zip

comment:12 Changed 11 years ago by dreammaster

Fixed - and thanks for the help in identifying. It was a problem that the Catriona hotspot was only active if the player was in the same room - the hotspot is needed for displaying the associated messages, which in this case weren't needed anyway, since the player wasn't in the room.

comment:13 Changed 11 years ago by dreammaster

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.