Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#3483 closed defect (fixed)

COMI: wrong subtitles color

Reported by: SF/paletta Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

When I load a savegame of COMI (I think that savegames were generated with scummvm 0.9) the color of the subtitles are all the same between characters and wrong. Screenshot is attached.

Note that this problem go away when during a dialog with another character Guybrush select one of the phrase to choose. After that colors are right.

Also note that if I resave a game after having selected a phrase of a dialog, when I reload the game I have no more this problem. However if I load a game with this problem and resave it before choosing a dialog I'll have again the problem on next reload of this saved game.

This is on an Italian version of COMI, using Mac OS X 10.4.11. I have the same problem with 0.10.0 or 0.11.0svn (2007-12-02).

I'll also attach one of the savegames with the problem.

Ticket imported from: #1846049. Ticket imported from: bugs/3483.

Attachments (2)

scummvm00000.png (240.6 KB ) - added by SF/paletta 12 years ago.
comi.s19 (106.0 KB ) - added by SF/paletta 12 years ago.

Download all attachments as: .zip

Change History (9)

by SF/paletta, 12 years ago

Attachment: scummvm00000.png added

by SF/paletta, 12 years ago

Attachment: comi.s19 added

comment:1 by SF/paletta, 12 years ago

File Added: comi.s19

comment:2 by cyxx, 12 years ago

ScummVM 0.9.0 didn't use the correct font at all in COMI, so savegames made at the time (version <= 68) contain wrong information.

To fix this, possible solutions would be to re-run the scripts setting up the charsets on savegame load, or setting _string[0]._default.charset to a 'sane' value (1 ?), or something else...

Reference tracker item : https://sourceforge.net/tracker/index.php?func=detail&aid=1036707&group_id=37116&atid=418820

comment:3 by fingolfin, 12 years ago

Priority: normallow

comment:4 by fingolfin, 12 years ago

Lowering priority. This only affects savegames made with older ScummVM releases.

comment:5 by fingolfin, 12 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:6 by fingolfin, 12 years ago

I implemented the workaround as suggested by cyx, i.e. setting _string[0]._default.charset to 1 when loading a V68 or older savegame.

comment:7 by SF/paletta, 11 years ago

The workaround works fine, but I would report a little issue with that: when loading a savegame that already has some sentence in it the color are wrong, they however last only for that screen and get fixed on next sentence (so, before selecting a sentence of Guybrush during a dialog with another character as was before the fix).

The issue is small and maybe it could let be as is, but if it would require only a small change it would be nice to have.

Thanks

Note: See TracTickets for help on using tickets.