Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3421 closed defect (fixed)

PALM: AGI games don't throw error when save path is not set

Reported by: SF/madmanguruman Owned by: eriktorbjorn
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Leisure Suit Larry 1

Description

- Version 0.10.0 on a palmOne Tungsten T5
- using the DOS/PC version of LSL1
- game and skin in local memory; LSL1 files on SD card
- no default save directory specified in scummvm.ini
- when trying to save a game to any slot, after specifying a description and pressing 'Do as I say!' the game reports that saving is successful; scumm.log reports otherwise:

Using configuration file: /PALM/Programs/ScummVM/scummvm.ini
Looking for lsl1
Trying to start game 'Leisure Suit Larry in the Land of the Lounge Lizards'
WARNING: Sound initialization failed.!
Initializing sound:
sound: envelopes enabled (decay=1000, sustain=100)
Seting up for version 0x2440

AGI engine 0.10.0 is ready.
Emulating Sierra AGI v2.440
Loading directory: logdir
Loading directory: picdir
Loading directory: viewdir
Loading directory: snddir
Loading objects: object
Decrypting objects... done.
Reading objects: 21 objects read.
Loading dictionary: words.tok
Running AGI script.
script.size(144)
Game ID: "LLLLL"
cancel.line
cancel.line
cancel.line
cancel.line
cancel.line
cancel.line
cancel.line
WARNING: Can't create file 'LSL1.000', game not saved!

Saving *does* work if a path is specified in scummvm.ini - the game engine should report that saves are not successful, in my opinion.

Ticket imported from: #1808163. Ticket imported from: bugs/3421.

Change History (9)

comment:1 Changed 12 years ago by fingolfin

Owner: set to SF/chrilith
Summary: [PALM] Cannot save LSL1 gamePALM: Cannot save LSL1 game

comment:2 Changed 12 years ago by bluegr

Gave a better description (IMHO) to this

comment:3 Changed 12 years ago by bluegr

Summary: PALM: Cannot save LSL1 gamePALM: AGI games don't throw error when save path is not set

comment:4 Changed 12 years ago by eriktorbjorn

I believe this was fixed about two months ago in the development version of ScummVM. See bug #1767237.

comment:5 Changed 12 years ago by SF/madmanguruman

I cannot test this as the ENTER command seems not to work on the latest Palm SVN build, meaning that I cannot get into the game to save.

comment:6 Changed 11 years ago by sev-

What is the status of this item?

comment:7 Changed 11 years ago by eriktorbjorn

As I said, I believe it was fixed months ago. I don't know if anyone has built a new Palm version since then, though.

comment:8 Changed 11 years ago by sev-

Indeed, just checked the code. The issue is gone.

comment:9 Changed 11 years ago by sev-

Owner: changed from SF/chrilith to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.