Opened 13 years ago

Closed 13 years ago

#3408 closed defect (fixed)

IHNM: Problem in saving

Reported by: SF/gerinych Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: I Have No Mouth

Description

ScummVM version: Daily snapshot September 22, 2007, 5:47 am Language: English, Russian (tried on both) Version: Talkie CD, DOS Platform: Win32 (Windows Vista) Every time I go to save my game, the program crashes onto the desktop. This bug can be reproduces by pressing F5 or clicking on the floppy icon in the bottom-right corner, then clicking on "Save". I thought that it was the problem with Windows Vista, as I have tried to run ScummVM on it for the first time, but when I tried to save the game using another game (Gobliins 2 CD), it saved normally. This is all information I have right now.

Ticket imported from: #1800276. Ticket imported from: bugs/3408.

Change History (20)

comment:1 by SF/gerinych, 13 years ago

Summary: Problem in savingIHNM: Problem in saving

comment:2 by sev-, 13 years ago

Weird. Works well over here.

May you run ScummVM with parameter '-d 11' and provide last 10 lines of the log which ScummVM prints out.

comment:3 by SF/thello, 13 years ago

I'm having this problem as well. I've run the game with the -d 11 parameter, but I can't seem to find where the log is saved or what the log is called. Let me know and I should be able to give you the info.

comment:4 by bluegr, 13 years ago

It works over here as well... weird

Have you set the save path in the ScummVM options screen? ("Paths" tab)

comment:5 by bluegr, 13 years ago

Owner: set to bluegr

comment:6 by SF/gerinych, 13 years ago

I tried setting the path to save files to my C: drive and when I try to get into F5 menu, the game freezes hardcore. Then I treid to run ScummVM with -d 11, and the console gave a lot of weird things, which is not what I get when I run without -d 11. And I can't find the log file as well. I don't know if this matters, but the label on the CD is NOMOF1017.

comment:7 by sev-, 13 years ago

Those weird things ARE the log. So, please, post here 10 or so last ones.

comment:8 by SF/thello, 13 years ago

ScummVM crashes completely, along with the window logging things. Unless there's a physical copy being saved somewhere that I can access after the crash, I'm not sure what I'm supposed to post.

comment:9 by bluegr, 13 years ago

Run ScummVM as: scummvm.exe -d11 > C:\scummlog.txt

Reproduce the crash and attach C:\scummlog.txt here

comment:10 by bluegr, 13 years ago

Er sorry, that should be: scummvm.exe -d 11 > C:\scummlog.txt

(forgot the space after the -d and before 11)

comment:11 by SF/gerinych, 13 years ago

Now the ScummVM doesn't wanna run.

comment:12 by SF/gerinych, 13 years ago

Sorry to double post, I took a screen of it crashing, it says: Stray argument '>' I'm guessing you have to run it "scummvm.exe -d 11 C:\scummvm.txt"?

comment:13 by SF/gerinych, 13 years ago

Sorry again, I was dumb enough to not to use cmd.exe. Guess what the console gave me? "getSaveFileName wrong idx!" What could that mean?

comment:14 by bluegr, 13 years ago

Never mind, I found what was wrong

Try the latest SVN version, this issue should be fixed now

Please reply if that fixed the issue for you

comment:15 by SF/gerinych, 13 years ago

Nope, the problem persists. I noticed that the website is saying that the latest SVN version was today, somewhere at 5 am, and the version I downloaded just now is 22:07:02. Is that how it's supposed to be?

comment:16 by SF/thello, 13 years ago

The problem still persists for me as well.

comment:17 by bluegr, 13 years ago

You need to get a precompiled binary which includes the fix for your issue, i.e. a binary dated 2007-09-23 onwards. I'm not sure when the precompiled binary is created, but if you download it tomorrow, it should be updated. The problem should be solved if the first entry in the save game list is "[New save game]" and you don't get an empty save list

comment:18 by SF/gerinych, 13 years ago

I checked the problem with the new snapshot, everything works fine now. Thanks.

comment:19 by bluegr, 13 years ago

Resolution: fixed
Status: newclosed

comment:20 by bluegr, 13 years ago

Great :) Closing

Note: See TracTickets for help on using tickets.