Opened 12 years ago

Closed 12 years ago

#3382 closed defect (fixed)

NIPPON: Protection Code Screen

Reported by: SF/yakkuz Owned by: peres
Priority: blocker Component: Engine: Parallaction
Keywords: Cc:
Game: Nippon Safes

Description

In the first screen when you have to insert a code (for protection reason and to "chose" your charachter) i notice a strange bug, with the stable version (0.10.0)i have to insert a valid code (throught answering the questions on the manual) to get the "wrong code" message and then, if i inser a valid code again (also the same)the game starts properly.

With the Daily build(0.11.0svn Aug 18 2007 23:27:40) i am unable to start the game at all, every code is always "wrong".

I try starting the game normally from dos prompt and if i put a right code it start at the first try.

Nippon Safes, Inc. Multilingual/DOS

Win32

Ticket imported from: #1777053. Ticket imported from: bugs/3382.

Change History (14)

comment:1 by SF/yakkuz, 12 years ago

Summary: Protection Code ScreenNIPPON:Protection Code Screen

comment:2 by fingolfin, 12 years ago

Owner: set to peres
Summary: NIPPON:Protection Code ScreenNIPPON: Protection Code Screen

comment:3 by peres, 12 years ago

Everything works well on my system (Win32 as yours). I would say you're not entering the right codes, but you say second chance works on 0.10.0... Anyway, please answer the following questions:

1 - has this bug never happened before?
2 - (on 0.10.0) what happens if you enter an invalid code as first try and then a valid one?
3 - (on 0.10.0 and svn) does it happen with every character?

Thanks

comment:4 by peres, 12 years ago

Everything works well on my system (Win32 as yours). I would say you're not entering the right codes, but you say second chance works on 0.10.0... Anyway, please answer the following questions:

1 - has this bug never happened before?
2 - (on 0.10.0) what happens if you enter an invalid code as first try and then a valid one?
3 - (on 0.10.0 and svn) does it happen with every character?

Thanks

comment:5 by SF/yakkuz, 12 years ago

1)This bug always happen since e try the game

2)If i enter an invalid one and then a valid i get the "wrong code" message, so, to start the game i could also insert in the order: Invalid,Invalid,Valid(with wrong message) and Valid. Two consecutvie Valid codes.

3)Yes, with every charachter i try to chose.

On the SVN i get ever an invalid code...no matter what i insert. I try deleting the old scummvm.in and downloading a new package of 0.10.0 to avoid a possibly file corruption, but it's the same...it sound really strange.

comment:6 by SF/yakkuz, 12 years ago

I Just try on a fresh installed XP Machine only to be sure that is not something related to my HW (Ok, i know it's a stupid idea, but i was just installing the Os on a new pc, so i make a try ;) )...indeed i get the same "error"..

With the last SVN (21-8 12:24:06)i could not chose the character, every code i insert, it says it's wrong.

With the Stable 0.10.0 i have to insert a right code two times...

In Dos-Prompt or DOSBOX...it accept the Code at the first time if is it correct.

It's very strange...essentially the game protection reposes only on 6 Question which have three possible answer each associated with a
"code" chosen between 9...

I also try with different language (just to be sure it was not a language-related problem)...excluding that my game files are someway corrupted, is it possible that there different version with different copy protection system? Howewer this don't explain the fact that with the 0.10.0 it works on the second try..

I'm sorry i report this being unable to help you to reproduce it :(

comment:7 by sev-, 12 years ago

Raising priority. This is a release-critical bug.

comment:8 by sev-, 12 years ago

Priority: normalblocker

comment:9 by peres, 12 years ago

User was trying the wrong protection codes. Version 0.10.0 used to work because of a bug in code verification which was fixed in revision 27463.

I'm rejecting this issue as invalid.

comment:10 by peres, 12 years ago

Resolution: invalid
Status: newclosed

comment:11 by peres, 12 years ago

Resolution: invalid
Status: closednew

comment:12 by peres, 12 years ago

Reopening this issue as it needs deeper examination.

comment:13 by SF/yakkuz, 12 years ago

peres (thank you mate :D ) seems to have located the problem and the game should work after rev 29799.
I'll try during next week as soon as i have some spare time.

Regards.

comment:14 by peres, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.