Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3372 closed defect (duplicate)

WINCE: consecutive left click bug

Reported by: SF/stimmscumm Owned by: SF/knakos
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

my device : HTC TYTN
OS : windows mobile 6 professional(CE OS 5.1.195 build 17743.2.3.0)
Free internal memory : 42.5 mb
Free storage card memory : 30 mb
free ram : from 20 mb to 23.5 mb

Im using scummvm for wince port version 0.10.0 stored on memory card and the games are stored on memory card too.

The problem occurs when playng day of the tentacle(i havent tested with the other games yet), but only occurs in scummvm wince port version 0.10.0 it does not occur in the older versions of scummvm wince port(i have tested with version 0.9.1 and its working fine).

when playing the game out of nowere it starts executing consecutive left clicks where the cross of the mouse is point at and it only stops when i put the free look configuration to the "manual left click" mode, when in free look "manual left click" mode the button i assinged to left click(softkey A) doesnt work so i change back to "auto execute left click" mode, then the problem stop and after a while it happens again. Although i could do the free look trick changing from "auto" to "manual" to "auto", its really annoying to happen every time im playing, the bug keeps going and coming back. Im sorry for my bad english and i hope i can be usefull with this report

Ticket imported from: #1769503. Ticket imported from: bugs/3372.

Attachments (1)

scummvm_stdout.txt (3.4 KB ) - added by SF/stimmscumm 12 years ago.
debug when occurred the problem

Download all attachments as: .zip

Change History (21)

by SF/stimmscumm, 12 years ago

Attachment: scummvm_stdout.txt added

debug when occurred the problem

comment:1 by fingolfin, 12 years ago

Owner: set to SF/knakos
Summary: consecutive left click bug on pdaWINCE: consecutive left click bug

comment:2 by SF/knakos, 12 years ago

it seems to me from the debugging output you provide that the trouble begins when pressing the 'volume up' key. can you verify this?

comment:3 by SF/stimmscumm, 12 years ago

actually it happens after i save the game.

comment:4 by SF/knakos, 12 years ago

maybe you have binded the 'volume up' key to bring up the save game dialog? anyway, I see a weird 'volume up' keystroke in the log. which action is that bound to?

comment:5 by SF/redjediuk, 12 years ago

Same auto click happens to me also when I play atlantis

Game is fine until I save and then the auto click appears. I have to quit then restart ScummVM for it to disappear.

ScummVM 0.10.0
Dell Axim X50
Windows Mobile 2003SE

comment:6 by SF/knakos, 12 years ago

Yes, but:

Which key have you bound to the 'Save game' action? Or are you using the toolbar icon to bring up the in-game menu?

comment:7 by SF/redjediuk, 12 years ago

For me I just click on the file folder in the bottom left of the ScummVM screen then click on the Save screen button.

I have no buttons hard coded.

comment:8 by spookypeanut, 12 years ago

Also happens for me with MI2, Dig, COMI.

Jubanka: I now have wince building capability (woohoo!), just tested in svn and it still happens. Let me know if you want me to test something :-)

comment:9 by SF/knakos, 12 years ago

when does this happen for you? what triggers it? Is it totally random, or after saving a game? also, pasting your stdout file here will help.

comment:10 by spookypeanut, 12 years ago

It always (and only) happens after saving a game, whether I bind the menu to a key or not. The workaround is to pop the menu up again, and it stops.

stdout here:

Using configuration file: scummvm.ini

Sound opened OK, mixing at 11025 Hz

Lost mouse focus.

Got mouse focus.

Looking for monkey2

Trying to start game 'Monkey Island 2: LeChuck's Revenge'

Using gameid monkey2, variant (null), extra

Using MD5 '3686cf8f89e102ececf4366e1d2c8126'

Sound opened OK, mixing at 11025 Hz

Lost mouse focus.

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 31 1

Key up 31 1

Key down 158 application 5

Key down 11E f5

Key down 11E f5

Key up 158 application 5

Key up 11E f5

(0:1:0x9DE): Adding object 76 from room 9 into inventory

Key down 11E f5

Key up 11E f5

Key down 155 application 2

Key up 155 application 2

Key down D action

Key up D action

State loaded from 'monkey2.s01'

Key down 155 application 2

Key up 155 application 2

Key down 155 application 2

Key up 155 application 2

Key down 11E f5

Key up 11E f5

Key down D action

State saved as 'monkey2.s01'

Key down 11E f5

Key up 11E f5

comment:11 by SF/knakos, 12 years ago

I see. The problem manifests itself when pressing the "Menu" action *key*, e.g. there is no problem when showing the menu by *tapping* on the menu icon in the tool bar, right? Also do you have the same device as reported here?

comment:12 by spookypeanut, 12 years ago

I tested both clicking on the button and mapping a buttton, and it happens on both. The paste below was from clicking on the menu icon. If you like I can make doubly sure and unmap the key before I start ;-)

I have a PocketLOOX N560 (WM5, VGA).

comment:13 by SF/knakos, 12 years ago

does this thing still persist? I cannot reproduce it at all with current svn (meaning: I cannot get any key to get "stuck" at all no matter how hard I try). Setting to pending.

comment:14 by SF/knakos, 12 years ago

Status: newpending

comment:15 by spookypeanut, 12 years ago

Yes, this bug persists on the release candidate for 0.11.0. Just to clarify, it is not about a particular button "sticking": the game seems to be receiving LMB-click events at regular, v frequent intervals (about 5 or so a second it seems), wherever the mouse cursor is at the time. Like I said before, it is possible to duplicate the problem (on my device at least) without a single button press, so it's not button related.

comment:16 by SF/knakos, 12 years ago

OK. This is too weird and quite possibly specific device related. I am going to need a complete and detailed rundown on how this issue manifests itself. I mean like set debuglevel=1 then "click on scummvm.exe, double click on dott in the launcher.... etc". Furthermore I'll need the [scummvm] section of your scummvm.ini and the stdout/stderr files. Since you (spookypeanut) say that it isn't keyboard related, please do not touch the keyboard for the duration of this test. Try reproducing without loading a savegame if possible. If you cannot attach files to this bug report, feel free to open another one and post the link to it here for reference.

comment:17 by SF/knakos, 12 years ago

Status: pendingnew

comment:18 by spookypeanut, 12 years ago

As suggested, I have started a new bug so that I can attach files. See:
https://sourceforge.net/tracker/index.php?func=detail&aid=1863961&group_id=37116&atid=418820

comment:19 by SF/knakos, 12 years ago

dupe of #1863961

comment:20 by SF/knakos, 12 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.