Opened 12 years ago

Closed 12 years ago

#3325 closed defect (fixed)

COMI: Wrong music playing...

Reported by: SF/thunderpeel2001 Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I've just been to Danjer Cove, for the first time, and walked the plank a few times. Now I'm back at Porto Pollo the same music from Danjer Cove is still playing. Even in places like Blonde Beard's...

It's but annoying, but only a minor bug.

Attached savegame.

Ticket imported from: #1757010. Ticket imported from: bugs/3325.

Attachments (4)

comi.s11 (84.2 KB ) - added by SF/thunderpeel2001 12 years ago.
Bad music…
comi.s12 (71.3 KB ) - added by SF/thunderpeel2001 12 years ago.
100% Repeatable bug - Prior to it happening
comi.s30 (68.7 KB ) - added by SF/thunderpeel2001 12 years ago.
SVN: Before bug (go to ship to hear the bug)
comi.s31 (81.9 KB ) - added by SF/thunderpeel2001 12 years ago.
SVN: After bug (wrong music playing everywhere on the island).

Download all attachments as: .zip

Change History (24)

by SF/thunderpeel2001, 12 years ago

Attachment: comi.s11 added

Bad music...

comment:1 by SF/thunderpeel2001, 12 years ago

Summary: Wrong music playing...COMI: Wrong music playing...

by SF/thunderpeel2001, 12 years ago

Attachment: comi.s12 added

100% Repeatable bug - Prior to it happening

comment:2 by SF/thunderpeel2001, 12 years ago

Update: This actually appears to be a 100% repeatable bug :( Attached new savegame. Simply use the rowboat to get to the Sea Cucumber. Climb on board. Get forced to walk the plank (you've got no control over this) and the same music will keep playing over and over (and over). No matter where you go on the island. Blonde Beard's. Voodoo N' Things. Whereever. Help! :(

File Added: comi.s12

comment:3 by fingolfin, 12 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 by fingolfin, 12 years ago

Owner: set to aquadran

comment:5 by SF/thunderpeel2001, 12 years ago

The bug was found on Vista32 running the latest stable release, "0.X.0". The game is the English version. Unfortunately attempts to reproduce the bug on SVM have failed because SVN crashes on attempting to load the savegame files from "0.X.0" :(

by SF/thunderpeel2001, 12 years ago

Attachment: comi.s30 added

SVN: Before bug (go to ship to hear the bug)

comment:6 by SF/thunderpeel2001, 12 years ago

Well, I'm not sure if it's a bug that the SVN version crashes when it loads save files from 0.X.0? Did either way I've tested it again in SVN and the same thing happens: The music doesn't stop playing once you've been forced to walk the plank. I'll upload two new files (one before and after the bug occurs) for the SVN build.

Thanks.
File Added: comi.s30

by SF/thunderpeel2001, 12 years ago

Attachment: comi.s31 added

SVN: After bug (wrong music playing everywhere on the island).

comment:7 by SF/thunderpeel2001, 12 years ago

Attached save game for SVN build (after bug has occurred with wrong music playing throughout Plunder Island).
File Added: comi.s31

comment:8 by SF/thunderpeel2001, 12 years ago

UPDATE: Please disregard everything I've said about SVN COMI not being able load files from 0X0. For some reasons my SVN Curse of Monkey Island crashes when I load savegames... period!

comment:9 by fingolfin, 12 years ago

That "crash on load" bug in SVN was fixed yesterday.

comment:10 by SF/thunderpeel2001, 12 years ago

Tested using new SVN build (without the 'load' crashes) and the bug is still present. Any of the supplied savegames are now usable for finding the bug. It seems the missing music change occurs when it cuts to Guybrush back in his row boat after walking the plank. I think it should change to a different piece of music there, but doesn't. If Guybrush makes into in LeChimps quarters (after being tarred and feathered), and then out the porthole, the "curse" of the looping music is broken when Guybrush paddles away on the plank of wood.

comment:11 by eriktorbjorn, 12 years ago

I'm playing through CoMI with the latest snapshot, and I can confirm that it still happens.

I tried playing it with the original interpreter. It's a bit hard to make out, but I think the music that's left playing in ScummVM is the music from when the monkey crew appears. It's supposed to change when you jump off the plank, or when you're tarred and feathered. After that, it's supposed to go back to the ordinary music again.

Maybe it's related to bug #1861704 ("COMI: Wrong music when escaping from the snake"), or maybe that's just wishful thinking since I filed it. It does try to set the music sequence "seqAttack", but nothing seems to happen.

comment:12 by fingolfin, 12 years ago

What strikes me as odd about seqAttack and seqSnakeVomits: They use transitionTypes 8 and 9, yet our code makes no distinction at all between the two transition types. Aquadran?

comment:13 by aquadran, 12 years ago

yes, our code use as the same. originally there is small difference, but i can't currently interpret original code if it's matter for our implementation. one of them 8 or 9 have addition trigger which propably happen at the end of music sequence.

comment:14 by eriktorbjorn, 12 years ago

I don't think the plank/tar-and-feather scene music plays right yet, but at least the wrong music is no longer left playing when I use the latest SVN snapshot. So I guess this particular bug is fixed, but that some other features are still missing.

This is what the tar-and-feather scene can sound like in the original (running under Wine): http://www.update.uu.se/~d91tan/ScummVM/tarnfeather.ogg

comment:15 by aquadran, 12 years ago

eriktorbjorn: can you update status with latest svn tree ?

comment:16 by eriktorbjorn, 12 years ago

I don't noice any difference from the last time, i.e. it still doesn't seem to play quite right.

comment:17 by aquadran, 12 years ago

how about this time ? i tried that plank/tar-and-feather scene it seem the same as recorded ogg file.

comment:18 by aquadran, 12 years ago

eriktorbjorn: I did some change for transition 9, it might affect on transition 4 too. Can try again ? :)

comment:19 by eriktorbjorn, 12 years ago

That seems to have fixed it.

comment:20 by aquadran, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.