Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3322 closed defect (fixed)

ITE: crashes using compressed audio

Reported by: SF/vorph999 Owned by: bluegr
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

ScummVM crashes using compressed audio in
"Inherit the Earth" (German / CD) + additional
MUSIC.RSC from Wyrmkeep Patch #2

Audio was compressed using tool provided with
SVN Build 08.07.07

ScummVM Version used 0.11.0 SVN 16.07.07 Win32

The crash first appeared in Version 13(?).07.07

The error message is:

"DigitalMusicInputStream() wrong musicInfo!"

Using the uncomopressed gamedata, the game works
normally.

Ticket imported from: #1754613. Ticket imported from: bugs/3322.

Change History (9)

comment:1 Changed 12 years ago by fingolfin

Owner: set to bluegr
Summary: ScummVM crashes using compressed audioITE: crashes using compressed audio

comment:2 Changed 12 years ago by bluegr

I'm confused. Have you compressed music.rsc too, or have you just copied it to the game folder?

From what you're saying, it seems you've compressed all the game data files, but left music.rsc uncompressed, which confused the engine. I've changed the check for the digital music, so you can now have an uncompressed music.rsc file even if the rest of the game is compressed.

I'm not sure why you would want to have uncompressed music while the rest of the game is compressed, though, as music.rsc can be compressed as well

comment:3 Changed 12 years ago by bluegr

Please, try the latest SVN version and tell us if the problem is fixed

Note that music.rsc can be compressed as well

comment:4 Changed 12 years ago by SF/vorph999

I tried latest SVN (downloaded 18.07.07 6:30 GMT+1 - I don't know the exact version) and
the problem still occurs, I will give it another shot later today (Maybe your fixes are
not yet included).

I tried several configurations:

1.) all datafiles compressed (I forgot to mention that, of course, MUSIC.RSC was compressed too)

ITE.RSC
SCRIPTS.RSC
SOUNDS.CMP
MUSIC.CMP
VOICES.CMP

The used Gameversion is German/CD

Result: The game crashes showing the previously mentioned error message

2. I replaced the compressed MUSIC.CMP with the original MUSIC.RSC file of Wyrmkeep Patch #2

Result: The game crashes showing the previously mentioned error message

3. I removed the MUSIC.RSC File from the game directory leaving

ITE.RSC
SKRIPTS.RSC
VOICES.CMP
SOUNDS.CMP

Result: The game starts normally

My uncompressed English/CD Version is running with or without the MUSIC.RSC - I will
do another test later today using the English Game Version after compressing it's datafiles

Hope these Informations will help you...

comment:5 Changed 12 years ago by bluegr

That's strange indeed
What compression have you used? MP3, OGG or FLAC?
How big is your music.rsc file?

The SVN file at the time this was written is timestamped July 17, 2007, 4:42 pm. This doesn't include the changes I made, try a newer version please

comment:6 Changed 12 years ago by SF/vorph999

Hello,

as there is still no new version (I think I will give it a try tomorrow morning), I will you give some of the
information you requested:

- The compression used is OGG
- The size of the original music.rsc file is 50,4 MB (52894196 Bytes)

I compressed the datafiles of my english game version (music, voices & sounds) and gave it a shot using the current SVN Build - the game started without any problems (with and without music.cmp)

comment:7 Changed 12 years ago by bluegr

Ah so the problem is with the German version of ITE, that helps a lot

comment:8 Changed 12 years ago by bluegr

OK that was a silly mistake from my behalf. I forgot to include digital music information in ITE versions that did not originally have digital music (like the German version of ITE). It should be fixed now in the latest SVN version (should be dated after Thu Jul 19 00:40:11 2007 UTC, which was when the fix for this issue was submitted).

Closing this. If you're still having problems, feel free to reopen this bug report

comment:9 Changed 12 years ago by bluegr

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.