Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3285 closed defect (fixed)

Elvira 2: Strange behavior a - counter of P.P.

Reported by: SF/clerynka Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Elvira 2

Description

Amiga Eng, PC Eng/Ger Version

A P.P. counter looks strange. Sometimes P.P. are selfrefreshing (usualy after a level up) but when you restore game a P.P. refreshing are freezed.

No savegame because a 1st moment with blocked P.P. is when you have 100 XP

so: Begin game as private eye

1 get rock on 1st screen (lower right) 2 go to door and throw rock 3 enter, go forward, turn right and open door 4 turn left and step back (you have about 80/84 exp) 5 create a ice dart spell and cast this spell 2 or 3 times so your xp are greater than 100 and you have a 2nd level. now wait and look at P.P. points should be slowly refreshed so everything is allright :)

THEN!

Do it again (restart scumm and run elvira II) but beetwen point 4 and 5 SAVE and RESTORE this save. All looks as the same but a P.P. counter stuck :/ and P.P. are not refreshing.

Ticket imported from: #1746094. Ticket imported from: bugs/3285.

Change History (2)

comment:1 by Kirben, 12 years ago

The problem is fixed in ScummVM SVN, use the next snapshot of ScummVM 0.11.0svn. The timers for current time events, were not adjusted by the current time, when saving games.

Unfortunately the problem will still occur with old save games, so you will need to restart the game.

comment:2 by Kirben, 12 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.