Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3265 closed defect

PSP: Goblins 3 CD Crash

Reported by: SF/sfaok Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Goblins 3

Description

Using PSP with custom firmware (3.40oe) and Goblins 3 CD version (v1.000/DOS/English US) with compressed audio (ogg converted as stated in the readme) on ScummVM 0.10.0. The game will crash the PSP, freezing it up until it switches itself off. The bug occurs when the game attempts to play the 'bubble dialogue' parts usually when examing an object.

I was unable to reproduce this crash in the PC build.

Ticket imported from: #1742029. Ticket imported from: bugs/3265.

Change History (15)

comment:1 by fingolfin, 12 years ago

Owner: set to joostp

comment:2 by joostp, 12 years ago

Unfortunately I don't own the CD version of gob3, and the floppy version that I have doesn't exhibit this problem.

Therefore I have no idea how easy or hard this would be to fix.

Maybe DrMcCoy has an idea? Assigning it to him for now, as there seems no way to "notify" someone of an open bug otherwise.
Feel free to re-assign to me if this is not an engine bug.

comment:3 by joostp, 12 years ago

Owner: changed from joostp to DrMcCoy

comment:4 by DrMcCoy, 12 years ago

Hmm, I have no specific idea, but there is a lot going on when the game does that.
Is there a way to run the game with debugflags and save the output on the PSP?
If so, I'd like you to run the game with "-d1 --debugflags=DrawOpcodes,FuncOpcode" and attach the ouput here.

comment:5 by fingolfin, 12 years ago

Does it crash with uncompressed audio, too? (Assuming that is supported on the PSP?)

comment:6 by fingolfin, 12 years ago

Summary: PSP : Goblins 3 CD CrashPSP: Goblins 3 CD Crash

comment:7 by SF/zeek_the_yoshi, 12 years ago

I was asked to also include that this occurs in the Dreamcast port of ScummVM v0.10.0 as well. All other points load fine (animation, sound effects), but all "bubble dialogue" causes the Dreamcast to reset (Not freeze, reset).

Also cannot be reperformed on the PC build of the latest ScummVM.

comment:8 by spookypeanut, 12 years ago

Also happens on WinCE, all other details seem the same.

comment:9 by SF/onnojongbloed, 12 years ago

Seems to be similar to bug #1787239.

Try looking for a define called MAX_FILES_OPEN and increase it (might be set to 4).

comment:10 by joostp, 12 years ago

No, this is unrelated to #1787239 (how would changing a #define in a DS flash card's DLDI driver or libfat fix crashes on PSP, WinCE, DreamCast, etc.?)

Rather, this bug is/was due to an unaligned access in the gob engine, and has been fixed by DrMcCoy in SVN last night.
The only reason I haven't closed this bug yet is because I haven't confirmed the fix on PSP yet, even though I'm 99.9% sure this bug is now fixed.

comment:11 by SF/onnojongbloed, 12 years ago

The symptoms were similar and it could very well be that the file system was based of or mirrored (in terms of design) from another handheld console; ie the PSP. Unfortunately I can't make a checkout atm so I couldn't check.

I'm glad that this has been fixed.

comment:12 by fingolfin, 12 years ago

What is the status of this item?

comment:13 by fingolfin, 12 years ago

Status: newpending

comment:14 by SF/sf-robot, 12 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:15 by SF/sf-robot, 12 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.