Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3196 closed defect (wontfix)

SQ1: Double arrows on keypad input screen

Reported by: SF/metafox Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 1

Description

Space Quest I (2.2 1987-05-07 5.25/3.5"/DOS/English)
Win32 May 21, 2007 SVN

On the screen where you input the detonation code, there are two arrows. You can push the buttons successfully, but you have to click the white arrow above the keys on the keypad in order for the red button to line up properly.

Ticket imported from: #1722988. Ticket imported from: bugs/3196.

Attachments (1)

sq1.001 (1.3 KB ) - added by SF/metafox 12 years ago.
SQ1 savegame at Keypad Input

Download all attachments as: .zip

Change History (4)

by SF/metafox, 12 years ago

Attachment: sq1.001 added

SQ1 savegame at Keypad Input

comment:1 by sev-, 12 years ago

Summary: Double arrows on keypad input screenSQ1: Double arrows on keypad input screen

comment:2 by bluegr, 12 years ago

I got confused first, but then I understood you're talking about mouse cursors. In that screen a red cursor appears, which moves to the key that you click with the regular white cursor. The red cursor itself is not affected by mouse movement, but it can be moved using the arrow keys.

There is no mouse support in the original SQ1 AGI interpreter. Refer to:
http://www.spacequest.net/sq1/gameinfo.shtml
"The game uses 16 colors, a screen resolution of 160 x 200 pixels and does not support soundcards or mouse"

As such, the Sierra developers used a "cursor" in this screen, which can be controlled with the arrow keys, so that the player can "click" on the buttons using the keyboard. ScummVM adds mouse support to AGI games. Therefore, what you're describing is not a bug, the red cursor is merely how the original developers wanted to help the player interact with the buttons on the screen without using a mouse, but with the keyboard.

Closing this as it's not a bug, it's how the original game behaved and the "dual cursors" experienced here is because ScummVM implements mouse support in games which were not originally designed to be played with a mouse.

comment:3 by bluegr, 12 years ago

Owner: set to bluegr
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.