Opened 12 years ago

Closed 12 years ago

Last modified 8 months ago

#3172 closed defect (fixed)

GUI: Button overlapping

Reported by: SF/dinomersh Owned by: sev-
Priority: high Component: GUI
Keywords: Cc:
Game:

Description

For any game in 'Edit game > Audio' the 'Cancel button' overlap the 'Subtitle speed' field.

Ticket imported from: #1709323. Ticket imported from: bugs/3172.

Attachments (1)

gui-volume-tab.patch (5.5 KB) - added by fingolfin 12 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by sev-

Which resolution are you running GUI in? I.e. Which scale and is aspect ratio turned on or not. Also which version of ScummVM?

comment:2 Changed 12 years ago by sev-

Owner: set to sev-

comment:3 Changed 12 years ago by salty-horse

This is a regression from http://scummvm.svn.sourceforge.net/viewvc/scummvm?view=rev&revision=26056
It's still unreleased.

Even after squashing the widgets together, I don't think there's enough room for everything on that single tab.
A bit of screen real-estate could be gained if the notebook area was stretched a bit to the bottom, and if the tab labels were a bit shorter, but that would lose the aesthetic.

comment:4 Changed 12 years ago by salty-horse

The problem is visible on the modern theme with a resolution of 640x400 (aspect ratio correction turned off).

comment:5 Changed 12 years ago by sev-

This would be nice to fix before release but is not critical, since turning aspect ratio correction on is a possible workaround.

comment:6 Changed 12 years ago by sev-

Priority: normalhigh

comment:7 Changed 12 years ago by fingolfin

So one solution would be to move the volume settings to a "Volume" tab -- like we do in 320x200 resp. 320x240 mode. That would also resolve the crashing part of bug #1677997, wouldn't it?

Changed 12 years ago by fingolfin

Attachment: gui-volume-tab.patch added

comment:8 Changed 12 years ago by fingolfin

The attached patch reintroduced the volume tab in all resolutions, which fixes the problem reported here. I guess the THEME_VERSION sbould be incremented, though, but since I am not 100% sure whether that's true, I leave that to others to decide. Some general notes:

It might look nicer to "merge" the volume tab into the audio tab in the big resolution; but IMO, this alone is not justification enough. While we could work around it by adding a separate 640x400 mode description, IMO the extra effort to maintain yet another resolution in all themes. It's already a burden to maintain those we have right now (in particular, I wasn't able to test my patch with the PSP resolution, so i guess that should be tested by somebody first, too).

Furthermore, the current code was bad, because it did not only remove the volume tab, it also removed the "Override global volume settings" checkbox -- hence, in a bigger resolution you suddenly had a reduced set of options. That seems odd and arbitrary, hence bad. In fact, I'd prefer if we offered *higher* granularity.

Finally, I think we need to restructure the options dialogs someday anyway. Latest when we introduce selecting arbitrary MIDI devices (see RFE #1107956).
File Added: gui-volume-tab.patch

comment:9 Changed 12 years ago by sev-

Resolution: fixed
Status: newclosed

comment:10 Changed 12 years ago by sev-

Slightly improved patch has been committed.

comment:11 Changed 8 months ago by digitall

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.