Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#3126 closed defect (fixed)

SYMBIAN GOB2: failed to open intro.stk

Reported by: SF/malfet Owned by: anotherguest
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

Installed scummvm-070314-SymbianS60v3 on Nokia E61
Add game->pointed to directory->game was detected as Gobliins 2
But when I try to Launch it - application displays black screen and then exists.
C:\Data\ScummVM\scummvm.stderr.txt contains only one line(stdout.txt is empty):
dataFileOpen: Can't open intro.stk data file!

Though it could find it(i.e. when I renamed it it write different diagnostics into scummvm.stdout.txt)
Files is not corrupted(i.e. I can play the game using the same files with ScummVM for OS X)

Ticket imported from: #1682054. Ticket imported from: bugs/3126.

Change History (11)

comment:1 Changed 12 years ago by fingolfin

Summary: failed to open intro.stk using scummvm-070314-SymbianS60v3SYMBIAN GOB2: failed to open intro.stk

comment:2 Changed 12 years ago by fingolfin

And what was the error you got when you renamed the file?

comment:3 Changed 12 years ago by SF/malfet

If into.stk is renamed, than scummvm.stderr.txt is empy and scummmv.stdout.txt are following:
Using configuration file: C:\Data\ScummVM\scummvm.ini
Using joystick: Joystick
Looking for gob
Trying to start game 'Gob engine game'

comment:4 Changed 12 years ago by SF/malfet

No error message. Like in previous case application just closes itself. (I.e. I start Scummvm, choose Gobliins 2, click on start - screen is black for half a second and than phone back to ActiveStandby screen and if one runs Tasky it fails to find ScummVM among the list of running processes )

comment:5 Changed 12 years ago by sev-

What is the status of this item?

comment:6 Changed 12 years ago by fingolfin

Owner: set to anotherguest

comment:7 Changed 12 years ago by fingolfin

Anotherguest, any news on this one? Could you at least post a comment stating that you are aware of this issue, and/or whether you can reproduce it? Thanks!

comment:8 Changed 11 years ago by anotherguest

Could this be related to the missing exist() functionality?
Will test on latest svn version to see if the problem still exist.
(i.e. my own latest built code)

comment:9 Changed 11 years ago by anotherguest

Tested on 0.11.0 version and seems to work as intended.
(This without any exist patch).

comment:10 Changed 11 years ago by anotherguest

Status: newclosed

comment:11 Changed 11 years ago by sev-

Resolution: fixed
Note: See TracTickets for help on using tickets.