Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3126 closed defect (fixed)

SYMBIAN GOB2: failed to open intro.stk

Reported by: SF/malfet Owned by: anotherguest
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

Installed scummvm-070314-SymbianS60v3 on Nokia E61
Add game->pointed to directory->game was detected as Gobliins 2
But when I try to Launch it - application displays black screen and then exists.
C:\Data\ScummVM\scummvm.stderr.txt contains only one line(stdout.txt is empty):
dataFileOpen: Can't open intro.stk data file!

Though it could find it(i.e. when I renamed it it write different diagnostics into scummvm.stdout.txt)
Files is not corrupted(i.e. I can play the game using the same files with ScummVM for OS X)

Ticket imported from: #1682054. Ticket imported from: bugs/3126.

Change History (11)

comment:1 by fingolfin, 13 years ago

Summary: failed to open intro.stk using scummvm-070314-SymbianS60v3SYMBIAN GOB2: failed to open intro.stk

comment:2 by fingolfin, 13 years ago

And what was the error you got when you renamed the file?

comment:3 by SF/malfet, 13 years ago

If into.stk is renamed, than scummvm.stderr.txt is empy and scummmv.stdout.txt are following:
Using configuration file: C:\Data\ScummVM\scummvm.ini
Using joystick: Joystick
Looking for gob
Trying to start game 'Gob engine game'

comment:4 by SF/malfet, 13 years ago

No error message. Like in previous case application just closes itself. (I.e. I start Scummvm, choose Gobliins 2, click on start - screen is black for half a second and than phone back to ActiveStandby screen and if one runs Tasky it fails to find ScummVM among the list of running processes )

comment:5 by sev-, 12 years ago

What is the status of this item?

comment:6 by fingolfin, 12 years ago

Owner: set to anotherguest

comment:7 by fingolfin, 12 years ago

Anotherguest, any news on this one? Could you at least post a comment stating that you are aware of this issue, and/or whether you can reproduce it? Thanks!

comment:8 by anotherguest, 12 years ago

Could this be related to the missing exist() functionality?
Will test on latest svn version to see if the problem still exist.
(i.e. my own latest built code)

comment:9 by anotherguest, 12 years ago

Tested on 0.11.0 version and seems to work as intended.
(This without any exist patch).

comment:10 by anotherguest, 12 years ago

Status: newclosed

comment:11 by sev-, 12 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.