Opened 13 years ago

Closed 13 years ago

#3112 closed defect (duplicate)

SQ2: Walk glitch

Reported by: eriktorbjorn Owned by: eriktorbjorn
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

English DOS version
Latest SVN snapshot

After you have crash landed on the planet, if you walk towards the wreckage from behind, Roger doesn't stop until he's visible through the wreckage. This glitch does not happen with DOSbox or NAGI.

It could be a problem with checkPriority(). If I change that to always return 1, I can walk right through the wreckage. The corresponding function in NAGI appears to be obj_chk_control().

NAGI's objs_step_update() triggers when Y reaches 144 to move you back to 143. Our updatePosition() triggers when Y reaches 145 and moves you back to 144. Assuming they handle coordinates the same way, something's different.

(This was tested with a rather old version of NAGI. I haven't checked if there's a newer one.)

Ticket imported from: #1677840. Ticket imported from: bugs/3112.

Attachments (1)

sq2.000 (1.2 KB ) - added by eriktorbjorn 13 years ago.
Savegame right after the crash landing

Download all attachments as: .zip

Change History (5)

by eriktorbjorn, 13 years ago

Attachment: sq2.000 added

Savegame right after the crash landing

comment:1 by fingolfin, 13 years ago

Owner: set to sev-

comment:2 by fingolfin, 13 years ago

Sev, we have tons of AGI reports by now, but do we have anybody who is interested in looking at them? Looking at AUTHORS, I see aquadran, darkfiber, dsx and you listed.
As it is, there seems to be zero activity (this is not meant as critcism, just an observation). So, maybe we should either try to contact all of the above and ask them whether they are interested in looking at some of the reports; or we could try to find other interested people.
(and maybe if I am really bored, I'll have a look at some of these issues myself, but I have no experience so far with AGI).

comment:3 by eriktorbjorn, 13 years ago

Owner: changed from sev- to eriktorbjorn
Resolution: duplicate
Status: newclosed

comment:4 by eriktorbjorn, 13 years ago

This is a duplicate of bug #1648396 ("AGI : SQ2 / 2.0F / IBM / priority line").

Note: See TracTickets for help on using tickets.