Opened 13 years ago

Closed 13 years ago

Last modified 6 years ago

#3024 closed defect (invalid)

savegames may be saved but not loaded

Reported by: SF/dersebi Owned by: cyxx
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

I can save savegames just fine, but whe I try to load them ScummVM tells me the loading failed.
Console output for this:

WARNING: Info section could not be found!

Tested with Loom and Full Trottle (both CD versions; english).

The strange thing is: When I use the binary from the ScummVM website I can load those exact savegames just fine.

I am using latest svn as of now on Mac OS X (Intel if that matters).

ScummVM 0.10.0svn (Jan 29 2007 15:46:39)
Features compiled in: Vorbis MP3 zLib

No additional configure switches.

"broken" savegame attached...

Ticket imported from: #1647216. Ticket imported from: bugs/3024.

Attachments (1)

ft.s03 (21.0 KB ) - added by SF/dersebi 13 years ago.
FT savegame

Download all attachments as: .zip

Change History (15)

by SF/dersebi, 13 years ago

Attachment: ft.s03 added

FT savegame

comment:1 by SF/dersebi, 13 years ago

Summary: savegames may be saved bot not loadedsavegames may be saved but not loaded

comment:2 by cyxx, 13 years ago

Just a guess, but maybe an issue with zlib (on gzseek call) ?
Does it occurs if you compile with USE_ZLIB not defined (ie. ./configure --disable-zlib) ?

comment:3 by fingolfin, 13 years ago

Summary: savegames may be saved but not loadedOSX: savegames may be saved but not loaded

comment:4 by fingolfin, 13 years ago

Very odd, and definitely doesn't happen here (on PowerPC, though). What output does "configure" generate for you?

comment:5 by sev-, 13 years ago

Summary: OSX: savegames may be saved but not loadedsavegames may be saved but not loaded

comment:6 by sev-, 13 years ago

Indeed, we had similar report with bad zlib linked to ScummVM.

comment:7 by SF/dersebi, 13 years ago

Compiled with --disable-zlib the games don't even start.
Starting FT for example has the following output:

Looking for ft
Trying to start game 'Full Throttle'
(1:59:0x86): Unknown frame subChunk found : ZFOB, 24!

I am using a self-compiled zlib-1.2.3 (no configure switches...).

Normal ScummVM configure yields:

Running ScummVM configure...
Looking for C++ compiler... g++
Checking for compiler version... 4.0.1, ok
Checking hosttype... darwin8.8.1
Checking endianness... little
Running on x86... yes
Alignment required... no
Type with 1 byte... char
Type with 2 bytes... short
Type with 4 bytes... int
Checking whether building plugins was requested... no
Checking for Ogg Vorbis... yes
Checking for Tremor... no (Ogg Vorbis/Tremor support is mutually exclusive)
Checking for FLAC >= 1.0.1... no
Checking for MAD... yes
Checking for ALSA >= 0.9... no
Checking for zlib... yes
Checking for libmpeg2 >= 0.3.2... no
Checking for libfluidsynth... no
Checking for nasm... /usr/bin/nasm

Engines:
SCUMM [v7 & v8 games] [HE70+ games]
AGOS
Beneath a Steel Sky
Broken Sword 1 (without mpeg2 cutscenes)
Broken Sword 2 (without mpeg2 cutscenes)
Flight of the Amazon Queen
SAGA
Legend of Kyrandia
Gobli*ns
Cinematique evo 1
AGI
Touche: The Adventures of the Fifth Musketeer

Backend... sdl, assembly routines, HQ scalers, MT-32 emu
Looking for sdl-config... /usr/local/bin/sdl-config

Creating config.h
Creating config.mk

comment:8 by cyxx, 13 years ago

It seems you are trying to start a game compressed with the compress_san tool or similar. Resulting datafiles require zlib compiled-in support. So, can you test with your original/uncompressed data files ?

comment:9 by SF/dersebi, 13 years ago

OK, You are right.
Without Zlib (and with an uncompressed game) I can save and load just fine.

With Zlib only saving works.

Is this a problem with ScummVM or with my setup?

comment:10 by fingolfin, 13 years ago

Hard to say w/o more info about your setup, but most likely it's caused by your setup.

Normally the system's zlib is used and everything is fine. But maybe you have a different version installed somewhere (e.g. in /usr/local), which causes conflicts -- e.g. if the headers of the one version are used but it links against the other. Should normally not happen, but then...

What do you get when you do
locate libz.
?

comment:11 by SF/dersebi, 13 years ago

You were right. That did it.
I had to manually specify the zlib prefix to be /Developer/SDKs/MacOSX10.4u.sdk/usr.

Everything works as it should - I'm just getting an insanely large number ob warnings during the build process

...
/Developer/SDKs/MacOSX10.4u.sdk/usr/include/stdlib.h:188:6: warning: "__STDC_VERSION__" is not defined
...

But as long as nothing breaks I'm happy.
Thanks for the help - setting status to closed as this is aparently no ScummVM issue.

comment:12 by SF/dersebi, 13 years ago

Status: newclosed

comment:13 by sev-, 13 years ago

Owner: set to cyxx
Resolution: invalid

comment:14 by Strangerke, 6 years ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.