Opened 13 years ago

Closed 13 years ago

#2962 closed defect (fixed)

TOUCHE: Script bug in Rouen may render game uncompletable

Reported by: SF/cappuchok Owned by: cyxx
Priority: normal Component: Engine: Touche
Keywords: script Cc:
Game: Touché: The Adventures of the Fifth Musketeer

Description

Tested with Win32 ScummVM SVN build 2006-12-20
Game version: English Talkie CD

In the cathedral at Rouen, when you are supposed to use the rope on the torch, you must not leave the cathedral before solving the torch+rope puzzle. If you leave the building (for example, if you forgot the rope), then go back, and use the rope on the torch, you will not get an error message but you will lose the rope from your inventory and the puzzle will not be solved, leaving the game in an uncompletable state.

This bug does not originate in the ScummVM implementation; it is present if you play the game in DOSbox or on an old computer as well.

I have attached a save game where you are inside the cathedral with everything you need to complete the puzzle. Go outside, then go inside again and use the rope on the unlit torch. You will get no message and the rope will disappear from your inventory.
Load the game again, and do the same thing without going outside first. The cut-scene will then play as it should.

Ticket imported from: #1622114. Ticket imported from: bugs/2962.

Attachments (1)

touche.14 (2.4 KB ) - added by SF/cappuchok 13 years ago.
Save game from which to test the script bug

Download all attachments as: .zip

Change History (9)

by SF/cappuchok, 13 years ago

Attachment: touche.14 added

Save game from which to test the script bug

comment:1 by sev-, 13 years ago

Owner: set to cyxx

comment:2 by sev-, 13 years ago

Gregory, can we do something to avoid this original game script bug?

comment:3 by SF/djdiabolik, 13 years ago

With version.. i have pass this point with build of 12.27.2006 without problems but i pass this point without exiting from cathedral...

comment:4 by cyxx, 13 years ago

Resolution: fixed
Status: newpending

comment:5 by cyxx, 13 years ago

Yes, Eugene, I think we can do something about it :)

It looks like a script isn't restarted when you leave and reenter the cathedral under certains conditions, I added a workaround to SVN. Please test.

comment:6 by SF/cappuchok, 13 years ago

Thanks, now it works even if I go outside before completing the puzzle.

comment:7 by SF/cappuchok, 13 years ago

Status: pendingnew

comment:8 by cyxx, 13 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.