Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2865 closed defect (fixed)

PS2: FOTAQ crashes on save

Reported by: SF/dsleaf67 Owned by: lavosspawn
Priority: high Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

First got a failed error the first time. Assumed since
I only had 630 K available MC. freed up 2 MB and this
time I got the 1 and 0 as if it was saving but stayed
there for 15 minutes. Then I had power off, but
seemingly ill effects on the memory card.

Ticket imported from: #1574210. Ticket imported from: bugs/2865.

Change History (17)

comment:1 by fingolfin, 13 years ago

Owner: set to lavosspawn
Summary: PS2:9.1RC1:FOTAQ crashes on savePS2: FOTAQ crashes on save

comment:2 by fingolfin, 13 years ago

For the record: the bug was reported for 0.9.1RC1 (?)

comment:3 by fingolfin, 13 years ago

Priority: normalhigh

comment:4 by lavosspawn, 13 years ago

This was fixed in the 0.9.1 final release.

(Race condition, the settings were written to the scummvm.ini file at the same time when the save game data was written. As the settings get stored using regular file I/O instead of using some kind of SaveFileManager mechanism this caused a crash in the memory card drivers)

comment:5 by lavosspawn, 13 years ago

Resolution: fixed

comment:6 by lavosspawn, 13 years ago

Status: newclosed

comment:7 by SF/dsleaf67, 13 years ago

Status: closednew

comment:8 by SF/dsleaf67, 13 years ago

First a question, is there a 9.1 final as the about box still says 9.0 and the date of the ELF file is Oct 7 2006. Second the saving in this still doesn't work. It doesn't seem I have to power off any more but similar conditions happen. First time save it gives me failed error and mouse stopped moving around. Hit start and backed out and regained mouse but now when I ask to save it seems to go through the motion, but I go back in to see my save and its not there.

comment:9 by fingolfin, 13 years ago

There is a 0.9.1 final package, aye: <http://prdownloads.sourceforge.net/scummvm/scummvm-0.9.1-ps2.zip?download>.

If your about box still says 0.9.0, then either you have the wrong version, or (less likely, but not impossible) this is a bug in the PS2 0.9.1 build.

Please confirm whether you downloaded and installed precisely this binary (if you are not sure, please re-install using the URL I gave above).

comment:10 by fingolfin, 13 years ago

Status: newpending

comment:11 by SF/dsleaf67, 13 years ago

Yes I wasn't sure either so I had already re-downloaded a couple of times. Each time that was the file name. The file dates are the same as what I have as well.

comment:12 by SF/dsleaf67, 13 years ago

Status: pendingnew

comment:13 by sev-, 12 years ago

This would be nice to resolve/investigate before the release

comment:14 by fingolfin, 12 years ago

Status: newpending

comment:15 by fingolfin, 12 years ago

So, I am confused. It this issue fixed now (it sounds as if it was fixed in 0.9.1), or not? Please clarify/close this item.

comment:16 by SF/sf-robot, 12 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:17 by SF/sf-robot, 12 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.