Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2772 closed defect (fixed)

Feeble: Missing Subtitle Crash

Reported by: SF/vhati Owned by: eriktorbjorn
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

2-CD English Mac Feeble Files
Windows ScummVM 0.10.0svn (08/08/2006)
(and 0.9.0 release)

The game completely dies (no debug popup) while talking
to Gardum, hidden outside HQ.

With subtitles off, the crash doesn't happen.

When they're on, this is the last one displayed.
"Distraction. Yeah, that's just what I was thinking."

I assume this is like the missing speech bug from the
6th.

Ticket imported from: #1536401. Ticket imported from: bugs/2772.

Attachments (2)

feeble.001 (1.1 KB) - added by SF/vhati 13 years ago.
Saved Game
ff-wrap.diff (821 bytes) - added by eriktorbjorn 13 years ago.
Patch against current SVN

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by SF/vhati

Attachment: feeble.001 added

Saved Game

comment:1 Changed 13 years ago by SF/vhati

Priority: normalblocker

comment:2 Changed 13 years ago by lordhoto

Changing the priority of the bug report changes nothing,
this is just used by the ScummVM team, we reset user made
priority changes. So please don't change it again and wait
until there is news on this.

comment:3 Changed 13 years ago by lordhoto

Priority: blockernormal

comment:4 Changed 13 years ago by eriktorbjorn

I can reproduce this crash - sometimes - but it's not that
the subtitles are missing. Rather, it looks like a bug in
SimonEngine::printScreenText() but, if so, one that matches
the original behaviour, as far as I can tell:

If I understand it correctly, when the text is being
prepared, the first line is limited to max 200 pixels. Each
subsequent line is limited to the length of the line
preceding it. So the lines get shorter and shorter.
Eventually, the lines get so short that even one word won't
fit on it.

I've attached a patch which changes the behaviour so that
each line is limited to (in this case) 200 pixels, no matter
what the preceding line was. That seems like more sensible
behaviour to me, but I'd like to hear Kirben's opinion,
before doing anything rash.

Changed 13 years ago by eriktorbjorn

Attachment: ff-wrap.diff added

Patch against current SVN

comment:5 Changed 13 years ago by eriktorbjorn

Owner: set to Kirben

comment:6 Changed 13 years ago by Kirben

Not surprising this bug was in the original version, since
printScreenText() is only used for hitbox names in the
original version.

The patch looks fine, I don't recall any hitbox names that
wrapped onto next time. So shouldn't be any visual
difference compared to the original version.

comment:7 Changed 13 years ago by eriktorbjorn

Committed to both branch and trunk, after further discussion
with Kirben.

comment:8 Changed 13 years ago by eriktorbjorn

Owner: changed from Kirben to eriktorbjorn
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.