Opened 13 years ago

Closed 13 years ago

Last modified 13 months ago

#2713 closed defect (fixed)

HE: Palette glitch (recent regression)

Reported by: eriktorbjorn Owned by: cyxx
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

Current SVN

In many of the HE games I have, there's a brief moment
where the wrong palette is used:

Pajama Sam 1
Pajama Sam 2
Pajama Sam 3
Spy Fox 1
Spy Fox 2
Spy Fox 3

For all the games except Spy Fox 3, the glitch happens
when the "It's a Junior Adventure" splash screen
appears. In Spy Fox 3, it happens on the Infogrames
logo screen.

I haven't figured out exactly why this happens, but it
appears to have something to do with revision 23216,
"Add cyx's patch for bug #1035739 - SCUMM/SMUSH: Ugly
palette change when video finishes".

The glitch is not present in 0.9.0, thankfully.

Ticket imported from: #1513622. Ticket imported from: bugs/2713.

Attachments (1)

1513622.diff (747 bytes ) - added by cyxx 13 years ago.
Possible fix

Download all attachments as: .zip

Change History (7)

comment:1 by eriktorbjorn, 13 years ago

Owner: set to Kirben

comment:2 by Kirben, 13 years ago

Owner: changed from Kirben to cyxx

comment:3 by Kirben, 13 years ago

The cause of the problem, is the location of updatePalette
() in main loop has changed for earlier games.

Judging by original games, the correct location for palette
update in main loop would be right after palManipulate().

by cyxx, 13 years ago

Attachment: 1513622.diff added

Possible fix

comment:4 by cyxx, 13 years ago

Well, there was no good reason to move the updatePalette()
call out of scummLoop().

So, we could just revert that part of the patch, but I think
it would be better to match the original interpreters and,
as Kirben suggested, move the updatePalette() call after the
other palette functions.

If other regressions occurs, we'll then try to deal with them.

Patch attached.

comment:5 by Kirben, 13 years ago

Resolution: fixed
Status: newclosed

comment:6 by digitall, 13 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.