Opened 13 years ago

Closed 12 years ago

Last modified 8 months ago

#2711 closed defect (fixed)

SYMBIAN: SCUMM scroll bug / crash

Reported by: SF/goetz_s Owned by: anotherguest
Priority: blocker Component: Port: Symbian
Keywords: Cc:
Game:

Description

As of scummvm-0.9.0-s60-v3-scumm.sis, the ScummVM build
for Symbian Series 60 3rd edition seems to crash often.

One situation where a crash occurs: In game

Atlantis (German/DOS/Floppy)

when entering the lower level of the submarine, the
screen should scroll vertically down to the lower
level. Instead ScummVM quits.

The same situation acts without problems on the latest
SVN build (before 0.9.0 release):

scummvm-060611-SymbianS60v3_scumm.sis

The crash/exit occurs in any zoom/graphics mode that
can be set.

Note about possible savegame incompatibility: With the
new version (0.9.0) a savegame was loaded from the
060611 build and continued, but the game continued for
a while before the crash. The savegame attached is
created with the current 0.9.0 release version.

Ticket imported from: #1513002. Ticket imported from: bugs/2711.

Attachments (2)

atlantis.s04 (24.9 KB) - added by SF/goetz_s 13 years ago.
Savegame to reproduce crash
atlantis.s02 (109.2 KB) - added by fingolfin 12 years ago.
FOA balloon crash, from bug #1531983

Download all attachments as: .zip

Change History (27)

Changed 13 years ago by SF/goetz_s

Attachment: atlantis.s04 added

Savegame to reproduce crash

comment:1 Changed 13 years ago by fingolfin

Summary: ScummVM Symbian S60 crashes on Nokia E60SYMBIAN:: Crash on Nokia E60

comment:2 Changed 13 years ago by fingolfin

Summary: SYMBIAN:: Crash on Nokia E60SYMBIAN: Crash on Nokia E60

comment:3 Changed 13 years ago by fingolfin

Owner: set to anotherguest

comment:4 Changed 13 years ago by Kirben

The problem would be due to grabRawScreen() not been
supported on the Symbian port, which is required by the
scrollEffects of the SCUMM engine now.

comment:5 Changed 13 years ago by SF/goetz_s

There seems to be a fix/workaround for vertical scrolling in
current svn build (06-09-17).

comment:6 Changed 13 years ago by SF/goetz_s

Status: newclosed

comment:7 Changed 13 years ago by SF/goetz_s

Well, in the 0.9.1 release build, this bug reappeared again
and can be reproduced with the attached savegame.

Maybe it is a memory problem and the solution could be to
have several smaller builds as on the cvsbuilds page.

The bug has not only been observed in Indy 4, but all games
which use vertical scrolling, i.e. indy4, mi2, mi.

comment:8 Changed 13 years ago by SF/goetz_s

Component: Engine: SCUMM--Unset--
Game: Indiana Jones 4
Status: closednew
Summary: SYMBIAN: Crash on Nokia E60SYMBIAN: Crash on Nokia E60 (Vertical Scroll bug)

comment:9 Changed 13 years ago by fingolfin

This bug is likely caused by grabRawScreen() not being implemented properly. See bugs #1513002, #1531983, #1581342, #1594636.
We should first establish that this is indeed the cause; then make sure it is fixed in the SVN trunk. In addition, porters might want to make a 0.9.1a release with
this issue fixed.

comment:10 Changed 13 years ago by SF/goetz_s

Priority: normalhigh

comment:11 Changed 13 years ago by Kirben

It was mentioned on devel mailing list in the past, that the Symbian ports use the SDL backend's version of the grabRawScreen() function. And stated below that a build between 0.9.x releases didn't have this issue, so I would suspect more of low memory issue.

Do the Symbian ports attempt to detect when it is out of memory and report error?

comment:12 Changed 13 years ago by sev-

Priority: highnormal

comment:13 Changed 13 years ago by sev-

Goetz, please, never play with priority settings unless you are going to fix the bug by yourself

comment:14 Changed 12 years ago by fingolfin

Priority: normalhigh
Summary: SYMBIAN: Crash on Nokia E60 (Vertical Scroll bug)SYMBIAN: Scroll bug / crash

comment:15 Changed 12 years ago by fingolfin

Some more similar crashes from tracker item #1531983 (which contains another savegame, too):

FOA - ballon goes off screen and there is a rapid scoll to the next part of the map.

DOTT - Laverne wants the human contest to be judged and approaches the judges, screen scrolls right.

DOTT - Hoagie washes the wagon, Storm begins and Franklin appears (I cannot remember a particular scrolling event for this one)

DOTT - Laverne says to Purple Tentacle, "you and what Army"; Purple says this Army and the screen scrolls to the right to display the army of purple tentacles.

Changed 12 years ago by fingolfin

Attachment: atlantis.s02 added

FOA balloon crash, from bug #1531983

comment:16 Changed 12 years ago by fingolfin

File Added: atlantis.s02

comment:17 Changed 12 years ago by fingolfin

Two more crash locations, from bug #1581342:

MI2: In the Booty island, at the reef, when we want to see under the reef, the program crashes because it's not able to scroll the screen

FOA: In Algeri, in the desert scene when you ride a camel, when you try to go in the next screens where you should find the camel-riding guards, the program crashes for the same reason.

comment:18 Changed 12 years ago by fingolfin

Summary: SYMBIAN: Scroll bug / crashSYMBIAN: SCUMM scroll bug / crash

comment:19 Changed 12 years ago by sev-

Priority: highblocker

comment:20 Changed 12 years ago by sev-

What is the status of this item?

comment:21 Changed 12 years ago by sev-

Raising priority. This is a release-critical bug.

comment:22 Changed 12 years ago by SF/goetz_s

I'm confident, that the bug won't be present in the upcoming release.

The svn builds scummvm-070522-SymbianS60v3_all.sis (current) and the previous two (scummvm-070314-SymbianS60v3_all.sis, scummvm-070322-SymbianS60v3_all.sis) did NOT crash in the sitations mentioned. It's the first thing I check when new svn builds are released, at least one situation in each game. :)

However, there is no guarantee, that it will work in the release version, as the 06-09-17 build worked, and in the later release 0.9.1 the bug reappeared. :)

comment:23 Changed 12 years ago by anotherguest

I'm setting this to fixed and keeping my thumbs in check. :-) I have updating memorylimits, stacksize etc, and all this might affect the outcome of this bug.

comment:24 Changed 12 years ago by anotherguest

Resolution: fixed
Status: newclosed

comment:25 Changed 8 months ago by digitall

Component: --Unset--Port: Symbian
Note: See TracTickets for help on using tickets.